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Chapter 1: Introducing the Forms Designer
Module

The Forms Designer module is an easy-to-use, flexible tool that gives you greater control over creating

forms. You control the format and location of the fields printed on your checks, vouchers, invoices,

requisitions, purchase orders, cash receipts, and customer statements (depending on which modules are

installed). Multi-tab menus make it easy to move, edit or delete each field. Control buttons handle

alignment and, with a mouse-click, shift fields to the top or bottom of the form. You can quickly change the

font, position or content of fields on each form you create, then save the form layouts for future use.

When printing checks, save money by purchasing blank check stock and using Forms Designer to print

headings, addresses, and the bank encoding for each checking account. On the stub portion of the

check, you can rearrange the order of columns or delete them. In the check body, you can add a logo,

edit the account title information, and move the payee name and address fields or the check amount and

date fields.

To create auto-signed checks, you simply insert the signature image into a field that you create. You can

restrict usage of the signature field by including a rule that restricts signature printing based on the

amount of the check.

Note: Formats are set up to use default currency and date settings.

To Add This Module

1. First the Forms Designer module must be added to the organization by the Administrator.

2. Either add Forms Designer to a current organization (Organization>Add a Module Wizard - Module

Panel), or select Forms Designer when creating a new organization (File>New Organization Wizard -

Modules Panel). For more information on these wizards, see the Administration guide.

3. Once Forms Designer has been applied to an organization, the Forms Designer menu selection is

available. This selection is integrated into the MIP Accounting menu selections (Reports>Forms

Designer).

4. There are Checklists available for setting up this module and its processes. Please refer to the online

help (Help>Contents and Index>Reference) for modular specific menu selections, checklists, and

common questions.
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Templates and Layouts

Templates

The system provides templates to help with organizing the placement of data, logos, or account

numbers, on the Forms Designer. The template displays shaded areas, which are there to assist in

accurately placing the fields within the layout. (These shaded areas are based on preprinted forms,

which can be purchased online. Refer to Preprinted Checks and Forms for a list of part numbers to use

when ordering.) These templates are a visual aid only; a template cannot be changed or printed. Select a

template to use as a basis for the new layout. Customize it to fit your needs, and then save it with a

layout name. If "None" is selected as the template, create a layout from scratch. To access these

templates, simply choose the "MIP Accounting Form" from the Choose Template drop-down list.

Additional templates cannot be added, and the exiting templates cannot be deleted.

The template also displays red lines as the margins. Fields entered that extend the red lines will be
automatically moved to fit within the lines when the form is printed. We therefore recommend keeping all

fields within these red lines, so the fields will print properly. The solid gray lines serve as 1" markers,

while the broken gray lines are ½" and ¼" markers. These lines only display when Show Grid is

selected, and they do not print.

Layouts

A template has a default layout associated with it. The layout consists of the fields (boxes) that print on

the form. The default layouts (that are already set up for you) make it easier to create custom layouts,

because we have already placed the boxes on the screen. Double-click in the boxes to complete the

information specific to your organization. Of course, the boxes or fields can be rearranged to different

areas on the layout, and new ones can be added as well. Then, save the layout created with a new

name.

Note: Changes cannot be saved to a default layout. If any changes are made to the layout, it must be

saved with a new name.

The table below displays all available layout types, and the templates and module associated with each

type. Some of the layout types may not be available depending on which modules are installed.

https://abilachecks.com/
FD_Preprinted_Checks_and_Forms.htm


Templates and Layouts

Layout Type Template Module

Write Checks For Laser MIP Accounting Forms:

None

Check

Check 21-Extended

Check 21

Canadian Check

For Continuous MIP Accounting

Forms:

None

Check

Check 21

General Ledger

A/P Checks For Laser MIP Accounting Forms:

None

Check

Check 21-Extended

Check 21

Canadian Check

For Continuous MIP Accounting

Forms:

None

Check

Check 21

Accounts Payable

A/P Vouchers None

MIP Accounting Forms - Voucher

Electronic Funds Transfer for

A/P
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Layout Type Template Module

A/R Receipts None

MIP Accounting Forms - A/R Receipt

A/R Billing

A/R Invoices None

MIP Accounting Forms - Invoice

MIP Accounting Forms - Canadian

Invoice

MIP Accounting Forms - Sales Related

Invoice

A/R Billing

Order Entry

Cash Receipts None

MIP Accounting Forms - Cash Receipt

General Ledger

Customer Statements None

MIP Accounting Forms - Customer

Statement

A/R Billing

Purchase Orders None

MIP Accounting Forms - Purchase

Order

Purchase Orders

PO Receipts None

MIP Accounting Forms - PO Receipts

Purchase Orders

Requisitions None

MIP Accounting Forms - Requisition

Electronic Requisitions

PO Receipt

Adjustments

None

MIP Accounting Forms - PO Receipt

Adjustments

Purchase Orders

PO Cancellations None

MIP Accounting Forms - PO

Purchase Orders



Templates and Layouts

Layout Type Template Module

Cancellations

Sales Orders None

MIP Accounting Forms - Sales Orders

Order Entry

Sales Fulfillment

Picking Ticket

None

MIP Accounting Forms - Sales

Fulfillment Picking Ticket

Order Entry

Sales Fulfillment

Packing Slip

None

MIP Accounting Forms - Sales

Fulfillment Packing Slip

Order Entry

Customer Return

Ticket

None

MIP Accounting Forms - Customer

Return Ticket

Order Entry

Payroll Checks For Laser MIP Accounting Forms:

None

Check

Check-No SSN/Bank

Check 21-Extended

Check 21-Extended No SSN/Bank

Check 21

Check 21-No SSN/Bank

Check-SSN Last Four

Check 21-SSN Last Four

Check 21-Extended SSN Last Four

For Continuous MIP Accounting

Forms:

Payroll
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Layout Type Template Module

None

Check

Check-No SSN/Bank

Check 21

Check 21-No SSN/Bank

Check 21-SSN Last Four

Check 21-Extended SSN Last Four

Payroll Vouchers For Laser MIP Accounting Forms:

None

MIP Accounting Forms - Voucher

MIP Accounting Forms - Voucher-No

SSN/Bank

MIP Accounting Forms - Voucher-

Extended

MIP Accounting Forms - Voucher-

Extended No SSN/Bank

MIP Accounting Forms - Voucher-SSN

Last Four

MIP Accounting Forms - Voucher-

Extended SSN Last Four

For Continuous MIP Accounting

Forms:

None

MIP Accounting Forms - Voucher

MIP Accounting Forms - Voucher-No

Payroll



Printing Your Documents

Layout Type Template Module

SSN/Bank

MIP Accounting Forms - Voucher-SSN

Last Four

Printing Your Documents
When you are ready to process and print the documents that were created using the Forms Designer

(such as check, invoice, or purchase order) use the appropriate form in the system.

Note that a check or invoice is not actually printed from the Forms Designer. Select the custom layout (with

the name it was assigned) from the Format drop-down list on the appropriate Load form in the system.

Then, the check or invoice prints using the layout that was created with the Forms Designer. Any

information that does not fit on the check or invoice prints on the next page.

Note: If Default is selected as the format (Reports>Forms Designer>OK button>Insert Table>Table

Properties>Detail tab; Generic Field Properties>Format tab; Database Field Properties>Format tab; or

Text Properties>Format tab), currency fields follow the formatting that was set up on the

Organization>Currency Setup form.

See the table below for a list of Layout Types and where each one is printed in the system. Some of the

layout types may not be available depending on which modules are installed.

Layout Type Menu Selection

Write Checks Activities>Check Writing>Write Checks>Write Checks

Transaction Entry Session>Load Checks form

A/P Checks or A/P Vouchers Activities>Accounts Payable>Pay Selected A/P Invoices>Load

Checks/Vouchers form

A/R Invoices or A/R Receipts Activities>Accounts Receivable>Print/Email Calculated

Invoices or Reprint Historical Invoices>Load Invoices form

Customer Statements Activities>Accounts Receivable>Customer Statements>Load

Statements form

Purchase Orders Activities>Purchase Orders>Create/Modify Purchase

Orders>Load Purchase Orders form

PO Receipts Activities>Purchase Orders>Process Receipts>Load Purchase

MIP Fund Accounting
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Layout Type Menu Selection

Order Receipts form

PO Receipt Adjustments Activities>Purchase Orders>Adjust Receipts>Load Purchase

Order Receipt Adjustments form

PO Cancellations Activities>Purchase Orders>Cancel Items>Load Purchase

Order Cancellations form

Sales Order Activities>Accounts Receivable>Enter Orders>Load Sales

Order form

Sales Fulfillment Picking

Ticket

Activities>Accounts Receivable>Sales Order Fulfillment>Load

Picking Ticket form

Sales Fulfillment Packing Slip Activities>Accounts Receivable>Sales Order Fulfillment>Load

Packing Slip form

Customer Return Ticket Activities>Accounts Receivable>Customer Returns>Customer

Returns Detail>Load Customer Return Ticket form

Cash Receipts Activities>Receipt Writing>Load Receipts form

Requisitions Activities>Requisitions>Create/Approve Requisitions>Load

Requisitions form

Payroll Checks or Payroll

Vouchers

Activities>Payroll>Print/Email Checks and Vouchers>Load

Checks/Vouchers form

Reprint Pay Stubs Activities>Payroll>Reprint Pay Stubs>Load Employee

ID/Check/Voucher Number form



Chapter 2: Creating Forms

These forms are used to create new form layouts from your existing forms.

Create New Layout

Access this form using Reports>Forms Designer.

Use this form to select the Layout Type, Printer Type, and Template. An existing layout can also be

opened with this form. Click to display the Forms Designer, allowing you to design or

change the layout. The Forms Designer helps in customizing your own layout to print checks, vouchers,

invoices, customer statements, cash receipts, purchase orders, receipts, receipt adjustments,

cancellations, vendor returns, sales orders, picking tickets, packing slips, customer return tickets,

requisitions, and payroll checks and vouchers.

The only types that are listed in the Layout Type box, are those associated with the modules installed. For

example, if the Accounts Payable module is not installed, "A/P Checks" does not appear in the Layout

Type drop-down list. Each Layout Type has a template associated with it. The system only allows a

template to be selected that is related to the Layout Type chosen.

Fields

Layout Type: Select a layout type from the drop-down list. The layout type, such as Write Checks, is

used to filter the templates available for Write Checks.

Printer Type Laser, Continuous: Select a printer type of either Laser or Continuous. Keep in mind that

the type of printer selected determines the size of the form. For example, for Continuous, the checks only

have one stub (stub>check). For Laser, the checks have two stubs (stub>check>stub).

Choose Template Pre-printed Stock: To print a form on pre-printed stock, make sure this check box is

selected, and then select a template for the chosen Layout Type using the drop-down list. Each Layout

Type has a template associated with it. Select "None" to create a custom layout from scratch. Note that

when the Pre-Printed Stock check box is selected and a new form is created and saved, any data that

does not fit on the first page prints on the next page; the system auto-increments to match the pre-printed

numbers. However, if the Pre-Printed Stock check box is not selected and a new form is created and

saved; the same number is printed on all additional pages, associated with the document.

MIP Fund Accounting
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Open Layout Open Existing: Select this check box to open an existing layout. The drop-down list

displays a list of available layouts that have been created.

Tips:
Use the Print buttons to review the layout before the document is actually processed.

Create and design custom layouts using the Forms Designer. To open an existing layout, simply

select the "Open Existing" check box on this form, and choose it from the drop-down list.

Forms Designer

Access this form using Reports>Forms Designer>OK button.

Use the Forms Designer to create custom forms for printing checks, invoices, and so on. The top and

bottom buttons help with customizing the design of the layout.

Use the top buttons to open, copy, import, and save a layout; select print options; insert fields; and

display the grid lines on the screen.

After selecting a box (such as text box or table), use the bottom buttons to assign properties, align

boxes on the layout, and format selections.



Forms Designer

Tips:
Use the templates, that are already set up for you, to create a custom layout. Each Layout Type has a

template associated with it. Select a template of "None" to create a layout from scratch.

To hide the grid lines on the screen, click Show/Hide Grid "off."

To view the layout as it will actually print, click Print Preview .

All the buttons at the bottom of the form can be accessed by right-clicking on the layout.

To enter the bank routing number, account number, and check number, so that they will print on the

check in the special font required by the bank, see "Inserting MICR Code" (page 39).

To view step for adding a signature to a check or any other document, see "Adding a Signature using

Forms Designer" (page 37).

To restrict the usage of the signature box, see "Restricting Signature Usage" (page 38).

When working with foreign currency, if you need to format the foreign currency text, see "Foreign

Currency Format" (page 11).

Foreign Currency Format

When working with foreign currency, you might need to document your A/P Check in a different format,

such as:

In the above example, using pre-printed checks and the Forms Designer module, you can manually add

the Currency Text formatting option to each box. These fields will not be on the check by default. If you

have blank check stock, you must draw each separate box using the Forms Designer module, add the

labels, and the correct formatting Currency Text for each box to the checks manually. Note that the code

will count how many units are contained in the amount on the check based on the Currency Text

formatting option selected.
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Complete the following steps to format Foreign Currency text:

1. Choose Write Checks, A/P Checks, or A/P Vouchers.

2. Click the Insert Database Field button , and then draw a box on the layout.

3. Right-click in the box, and select Properties.

4. The Database Field Properties displays.

On the General tab, select "Document Amount" in the Select Database Field. Adjust the Size and

Position as needed.

On the Conditions tab, select Rules if appropriate.

On the Format tab, select your first Currency Text format, such as 10,000,000's Currency Text,

1,000,000's Currency Text, 100,000's Currency Text, 1,000's Currency Text, 100's Currency Text,

10's Currency Text, or Units Currency Text. Also, set up Alignment and Miscellaneous if

appropriate.

If you need to draw boxes around the Currency Text, on the Fonts & Borders tab on the Border

Style field, change "None" to "Solid". Select your width and color. You can also change your font

and background color on this tab.

5. Repeat steps 2 - 4 until all of the Currency Text formats are used

Tips:
Make sure that the correct number of units (in the ones place) displays in that field you just added. If it

is zero, the word zero should display.

If you want to add the Pound "£" symbol. Click the Insert Text button , and draw a box on the

layout. While the box is still selected, hold down the <Alt> key, type 0163 on the Key Pad, and release

the <Alt> key. The pound symbol displays.

The formatting option is available for all templates relating to A/P Checks and Write Checks and will

appear on any numeric data field.

Cents (or Pence, etc) will not be shown in the document amount fields. You will need to enter a text

field below the amount that reads: "Cents like in numerical amount" or "Pence as in figures."



Forms Designer Buttons

Inserting Fields on the Forms Designer

To insert text, a field, or a table on the Forms Designer:

1. Click the appropriate button at the top of the form.

Add text to the layout.

Add a field from a database table to the layout, such as vendor ID and document amount.

Add a generic field to the layout, such as system date and time.

Add a table to the layout.

Draw lines and boxes on the layout.

Add a graphic to the layout.

Insert MICR items on the layout, such as bank routing number.

2. Draw a box on the layout.

3. Click Properties to enter data, format a selection, change font and background color, or add a

border. You can also right-click or double-click in the box to display the Properties form.

4. After making your selections, click OK. These settings are saved with the layout.

Forms Designer Buttons

Close Layout: Use this button to close the Forms Designer.

Import Format: Use this button to select a Forms Designer file (*.FDN) to be imported

into the system.

New Layout: Use this button to select a new layout type, printer type, and template.

Open Layout: Use this button to open an existing layout.

Save Layout: Use this button to save the current layout.

MIP Fund Accounting
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Copy Layout: Use this button to make an exact copy of the current layout.

Print Setup: Use this button to select a printer and set up default printer information.

Print Preview: Use this button to preview the current layout.

Print: Use this button to print the current layout.

Select Template: Use this button to choose a different template as the basis for the

layout.

Find: Use this button to view a list of available layouts.

Reset: Use this button to reset the Insert buttons on this form. For example, if Insert

Text is "on," and it needs to be "off," click Reset.

Insert Text: Use this button to add text to the layout.

Insert Database Field: Use this button to add a field from a database table (such as

vendor ID, address, and document amount) to the layout.

Insert Generic Field: Use this button to add a generic field (such as system date and

time and organization name) to the layout.

Insert Table: Use this button to add a table to the layout. The table is used to select

the detail data that prints on the layout.

Insert Drawing: Use this button to draw lines and boxes on the layout. For example, a

box may need to be added around the Amount field, or lines may need to be drawn to

separate the columns in a table.

Insert Picture: Use this button to add a graphic to the layout. For example, a company

logo may be needed on a check or invoice.

Insert MICR: Use this button to enter MICR items (such as the bank routing number,

account number, and document number) on the layout, so that they print on the check

in the special font required by the bank.



Forms Designer Buttons

Show/Hide Grid: Use this button to either display or hide the grid lines on the screen.

Layout Left: Use this button to align the selections to the left.

Layout Right: Use this button to align the selections to the right.

Layout Top: Use this button to align the selections to the top.

Layout Bottom: Use this button to align the selections to the bottom.

For example, add three text boxes anywhere on the layout. Select the three boxes using the Shift

key. Click Layout Right , and all three boxes are moved to the right margin line.

Layout Vertical Center: Use this button to center the selections vertically.

Layout Horizontal Center: Use this button to center the selections horizontally.

Select All: Use this button to select all items on the layout.

Delete: Use this button to delete all selected items. It does not delete everything on

the layout, only the items selected.

Undo Last Action: Use this button to undo the last action performed.

Redo Last Action: Use this button to redo the last action performed.

Properties: Use this button to display one of eight Layout Properties forms,

depending upon which field was inserted. The Layout Properties form displays

properties for the entire layout, whereas the other Properties forms display properties

for the highlighted selection. Click the Properties button, right-click the selection, or

double-click the selection to display a Properties form. The Properties forms available

are: "Text Properties" (page 23), "Database Field Properties" (page 25), "Generic

Field Properties" (page 28), "Table Properties" (page 31), "Drawing Properties" (page

33), "Picture Properties" (page 35), "MICR Properties" (page 38), and "Layout
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Properties" (page 22).

Align Left: Use this button to align all selections with the left edge of the first item

selected.

Align Right: Use this button to align all selections with the right edge of the first item

selected.

Align Top: Use this button to align all selections with the top edge of the first item

selected.

Align Bottom: Use this button to align all selections with the bottom edge of the first

item selected.

For example, add three text boxes anywhere on the layout. Select the three boxes using the Shift

key. Click Align Left , and all three boxes align with the left edge of the first box selected.

Make Same Width: Use this button to adjust all selections to the same width as the

first item selected.

Make Same Height: Use this button to adjust all selections to the same height as the

first item selected.

Make Same Size: Use this button to adjust all selections to the same size as the first

item selected.

For example, if you select two text boxes on the layout, and then click Make Same Size , the

boxes both become the exact same size as the one selected first.

Send Back: When an item is on top of another one, an overlapping stack is created

on the layout. The top item covers a portion of the item beneath it. This button sends

the item to the back of a stack.

Bring Front: When an item is on top of another one, an overlapping stack is created

on the layout. The top item covers a portion of the item beneath it. This button brings

the item to the front of a stack.

Font: Use this button to change the font and size of the selection. If multiple items are

selected on the layout, the font and size changes for all items.

Text Color: Use this button to change the text color of the selection. If multiple items

are selected on the layout, the text color changes for all items.



Import Format

Bold: Use this button to bold the text in the selection. If multiple items are selected on

the layout, the text is bolded for all items.

Italic: Use this button to italicize the text in the selection. If multiple items are selected

on the layout, the text is italicized for all items.

Underline: Use this button to underline the text in the selection. If multiple items are

selected on the layout, the text is underlined for all items.

Left: Use this button to align the text to the left in the selection. If multiple items are

selected on the layout, the text for all items is aligned to the left.

Center: Use this button to center the text in the selection. If multiple items are

selected on the layout, the text for all items is centered.

Right: Use this button to align the text to the right in the selection. If multiple items are

selected on the layout, the text for all items is aligned to the right.

Import Format

Access this form using Reports>Forms Designer>OK button> Import Format.

Use this form to select a Forms Designer file (*.FDN) to be imported into the system.

Each layout created has two files associated with it: a *.FDN and a *.FDT. By default, both files are stored

in the Formats directory.

1. Specify a *.FDN file in the File name box, and then click OPEN.

2. Enter a Layout Name and Description on the Save Layout form, and then click the OK button to add

the format to the system.

3. Edit the imported layout accordingly.

Fields

Look in: Select the drive and folder for the location of the *.FDN file.

File name: Either select a file from the available list, or enter a file name. The system displays the

available *.FDN files in the current folder.
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Files of type: The system displays the file type (Forms Designer Files, *.FDN) in this box. Only *.FDN

files can be imported.

New Layout

Access this form using Reports>Forms Designer>OK button> New Layout.

Use this form to open a new Forms Designer layout. You will select the Layout Type, Printer Type, and

Template.

The only types that are listed in the Layout Type box are those associated with the modules installed. For

example, if the Accounts Payable module is not installed, "A/P Checks" does not appear in the Layout

Type drop-down list. Each Layout Type has a template associated with it. The system only allows a

template to be selected that is related to the Layout Type chosen.

Fields

Layout Type: Select a layout type from the drop-down list. The layout type, such as Write Checks, is

used to filter the templates available for Write Checks.

Printer TypeLaser, Continuous: Select a printer type of either Laser or Continuous. Keep in mind that

the type of printer selected determines the size of the form. For example, for Continuous, the checks only

have one stub (stub>check). For Laser, the checks have two stubs (stub>check>stub).

Choose Template Pre-printed Stock: To print a form on pre-printed stock, make sure this check box is

selected, and then select a template for the chosen Layout Type using the drop-down list. Each Layout

Type has a template associated with it. Select "None" to create a custom layout from scratch.

Tip: If printing a form on pre-printed stock, make sure the "Pre-printed Stock" check box is selected on

this form.

Open Layout

Access this form using Reports>Forms Designer>OK button> Open Layout.

Use this form to open an existing Forms Designer layout. Select a layout Name, and then the system

displays the layout's Description, Layout Type, and File Name.



Save Layout

Fields

Name: Select an existing layout from the drop-down list.

Description: The system displays the description associated with the layout.

Layout Type: The system displays the layout type, such as CDS for Write Checks.

File Name: The system displays the layout's file name.

Tip: In order to open an existing format created on another workstation, ensure that both your

workstation and the one originally used to create the format are mapped to the server using the same

drive path.

Save Layout

Access this form using Reports>Forms Designer>OK button> Save Layout.

Use this form to save the current Forms Designer layout. Only enter the Name and Description on this

form; the system completes the Layout Type and File Name.

When this layout is opened again using Open Layout , the Layout Type and File Name display on the

Open Layout form.

Fields

Name: Enter a unique name for the layout. The Drop-Down Lookup displays a list of existing layouts;

however, these layout names cannot be used again.

Description: Enter a description for the layout.

Layout Type: A layout type cannot be entered here. The system automatically applies the appropriate

type after clicking OK.

File Name: A file name cannot be entered here. The system automatically assigns a file name after

clicking OK, and it is saved in the Formats directory.
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Tips:
When a format is saved, another workstation cannot access it unless the other workstation is mapped

to the server using the same drive path.

Forms Designer files are saved in the \MIP Share\Formats directory.

Copy Layout

Access this form using Reports>Forms Designer>OK button> Copy Layout.

Use this form to copy all parameters from an existing Forms Designer layout to a new layout. The system

creates a new layout with the same settings as the original layout.

Fields

Copy From: Select an existing layout in which to copy.

Copy To: Enter a unique name for the new layout. Use the Drop-Down Lookup to see a list of existing

layouts; however, these layout names cannot be used again.

Description: Enter a unique description for the new layout.

Tip: Make a copy of a default layout and use the copy as a new layout. Simply select the default layout

from the Copy From box, such as Continuous Check, and assign the new layout a unique name in the

Copy To box. It is a good idea to give the new layout a Description that will help you recognize it easier.

Select Template

Access this form using Reports>Forms Designer>OK button> Select Template.

Use this form to choose another template as the basis for the Forms Designer layout.

Fields

Template Name: Select a template name from the drop-down list. The system displays only the

template names associated with the layout type chosen using Reports>Forms Designer>Create New

Layout.



Find

Tips:
Remember, a template has a default layout associated with it. The default layouts (that are already set

up for you) make it easier to create custom layouts, because the boxes have already been placed on the

screen. Double-click in the boxes to complete the information specific to your organization. Of course,

the boxes or fields can also be rearranged to different areas on the layout. Then, save the layout created

with a new name.

The default layouts cannot be overwritten. If changes are made, the layout must be saved with a new

name.

Find

Access this form using Reports>Forms Designer>OK button> Find.

The Find form is a general purpose form that provides an easy way to find the record or records needed.

Use the Find form to see all existing Forms Designer layouts. The layout Name, Description, and Type

display on the form, such as MIP Accounting Forms - Check, Format for Laser Drivers, Write Checks.

Fields

Find Table: Most records in the Find table are initially sorted on the first data column in ascending order.

(The column on which items are sorted has the symbol in the column heading.) However, records can

be sorted based on any column by clicking on the column heading.

Furthermore, by double clicking a sorting column heading again, the displayed items can be changed from

ascending to descending order, or vice versa.

Tips:

To select or clear all invoices in the table, click or respectively.

Click to delete the selected items from the data.
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Layout Properties

Access this form using Reports>Forms Designer>OK button> Properties.

Use this form to view properties for the current Forms Designer layout.

Fields

Layout Type: The layout type, such as A/P Checks.

Layout Size: The layout size, including the width and the height.

Printer Type: The printer type, such as Laser.

Printer: The printer, such as HP Laser Jet 5.

Unprintable Area Left, Right, Top, Bottom: The left, right, top, and bottom margins for the current

layout.



Chapter 3: Field Properties

Text Properties
Use this form to set up properties for a text box on the Forms Designer form, such as the font, color, and

border.

Text Properties - General Tab

Access this tab using Reports>Forms Designer>OK button>Insert Text> Properties.

Use this tab to enter the text to be displayed on the layout. The Size and Position of a text box can also be

determined. After all selections are made, click OK, and the system applies the text properties. These

settings are saved with the layout.

Fields

Display Text: Enter the text to display on the layout.

Size and Position: The system displays the size and position for the text box on the layout, but its

parameters can be changed if needed.

Left, Top: Enter the number, in inches, for the system to place the text box from the left and top edge of

the screen.

Width, Height: Enter the width and height of the text box.

Tip: Use the ruler at the top of the screen to help assist in placing fields on the layout.

Text Properties - Conditions Tab

Access this tab using Reports>Forms Designer>OK button>Insert Text> Properties.

Use this tab to select on which forms the text (that was entered on the General tab) appears.
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Fields

Rules: Select a rule to apply to the forms—All Forms, Last Form, Overflow Forms, or First Form.

For example, if the detail data for the check does not fit on one page, the system continues printing the

data on as many pages as needed.

All Forms - The text entered in the box prints on every page of the check. To add text at the bottom of

all pages saying "Check listing continues on next page," select this rule.

Last Form - The text prints only on the last page. To add text on the last page saying "This is the end of

check 1473," select this rule.

Overflow Forms - The text prints on all pages excluding the last page.

First Form - The text prints only on the first page.

Additional Rules Make Rule: Click the Make Rule button to set up a new rule. The Filter form appears,

allowing you to narrow down and more explicitly, specify the data to include on the forms.

Once the selections are complete, click OK on the Filter form to apply the rule. The Make Rule button is

only available on Purchase Order forms.

Text Properties - Format Tab

Access this tab using Reports>Forms Designer>OK button>Insert Text> Properties.

Use this tab to format and align the text on the layout.

Fields

Format: Select how the box is formatted. For example, for four places after the decimal, select the

0.0000 format. If Default is selected as the format, currency fields follow the formatting that was set up on

the Organization>Currency Setup form.

Alignment: Select where the characters appear in the text box.

Horizontal: The system left-aligns, centers, or right-aligns the text within the box, depending on which

option is selected.



Database Field Properties

Vertical: The system places the characters at the top, center, or bottom of the text box, depending on

which option is selected. Vertical alignment only applies to unwrapped text. If the "Wrap Text" check box

is selected, the Vertical box is disabled.

Miscellaneous Wrap Text: Select this check box to automatically wrap the characters within the box.

Otherwise, some characters may be truncated, depending on the width of the text box.

Text Properties - Fonts & Borders Tab

Access this tab using Reports>Forms Designer>OK button>Insert Text> Properties.

Use this tab to change the Font of the text and the Background Color and Border of the text box. When

applying a border, choose the width, style, and color.

Fields

Font: Click the Font button to change the font, style, and size of the text.

Back Color: Assign a color that fills the entire box. Click "Other" to customize a background color. (To

change the text color, click at the bottom of the Forms Designer.)

Style: Change the border style—None, Solid, Dash, Dot, DashDot, or DashDotDot.

Width: Change the border width. The width of the border can only be changed, if using a style of "Solid."

Color: Change the border color. Select "Other" to customize a border color.

Database Field Properties
Use this form to set up properties for the database field on the Forms Designer form, such as the font,

color, and border.

Database Field Properties - General Tab

Access this tab using Reports>Forms Designer>OK button>Insert Database Field>

Properties.

Use this tab to select a database field to be added to the layout, such as Vendor Name and Address,

Check, or Document Amount. Keep in mind that items in the Select Database Field drop-down list vary
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depending on what layout type is selected. For example, if creating an A/P check layout, items like the

Vendor ID and Vendor Name appear in the drop-down list. The Size and Position of the box/field on the

layout can also be determined.

After all selections are made, click OK, and the system applies the properties. These settings are saved

with the layout.

Fields

Select Database Field: Select the database field to display on the layout, such as Vendor Name and

Address, Check, or Document Amount.

The available fields are associated with the layout type selected on the Create New Layout form. Use the

drop-down list to see a list of available fields. The system automatically displays the most recent

information for the field.

Size and Position: The system displays the size and position for the box on the layout, but its

parameters can be changed if needed.

Left, Top: Enter the number, in inches, for the system to place the box from the left and top edge of the

screen.

Width, Height: Enter the width and height of the box.

Tips:
Use the ruler at the top of the screen to help assist in placing fields on the layout.

Additional fields are available if any user defined fields were created using Organization>Set Up User

Defined Fields.

The Units Currency Text formatting option is available by selecting the Document Amount Database
Field for all templates relating to A/P Checks and Vouchers, and Write Checks.

Database Field Properties - Conditions Tab

Access this tab using Reports>Forms Designer>OK button>Insert Database Field>

Properties.

Use this tab to select on which forms the field (that was selected on the General tab) appears.



Database Field Properties

Fields

Rules: Select a rule to apply to the forms—All Forms, Last Form, Overflow Forms, or First Form.

For example, if the detail data for the check does not fit on one page, the system continues printing the

data on as many pages as needed.

All Forms - The amount, such as $599 (USD), prints on every page. To print the "Document Amount" on

all pages, select this rule.

Last Form - The amount prints only on the last page.

Overflow Forms - The amount prints on all pages excluding the last page.

First Form - The amount prints only on the first page.

Database Field Properties - Format Tab

Access this tab using Reports>Forms Designer>OK button>Insert Database Field>

Properties.

Use this tab to format and align the text on the layout.

Fields

Format: Select how the box is formatted. For example, for four places after the decimal, select the 0.0000

format. If Default is selected as the format, current fields follow the formatting that was set up by the

Administrator on the Organization>Currency Setup form. Note that the Units Currency Text formatting

option is available by selecting Document Amount for all templates relating to A/P Checks and Vouchers,

and Write Checks.

Alignment: Select where the characters appear in the box.

Horizontal: The system left-aligns, centers, or right-aligns the characters within the box, depending on

which option is selected.

Vertical: The system places the characters at the top, center, or bottom of the box, depending on which

option is selected. Vertical alignment only applies to unwrapped text. If the "Wrap Text" check box is

selected, the Vertical box is disabled.
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Miscellaneous Wrap Text: Select this check box to automatically wrap the characters within the box.

Otherwise, some characters may be truncated, depending on the width of the box.

Database Field Properties - Fonts & Borders Tab

Access this tab using Reports>Forms Designer>OK button>Insert Database Field>

Properties.

Use this tab to change the Font of the text and the Background Color and Border of the box. When

applying a border, choose the width, style, and color.

Fields

Font: Click the Font button to change the font, style, and size of the text.

Back Color: Assign a color that fills the entire box. Click "Other" to customize a background color. (To

change the text color, click at the bottom of the Forms Designer.)

Style: Change the border style—None, Solid, Dash, Dot, DashDot, or DashDotDot.

Width: Change the border width. The width of the border can only be changed, if using a style of "Solid."

Color: Change the border color. Select "Other" to customize a border color.

Generic Field Properties
Use this form to set up properties for the field on the Forms Designer form, such as the font, color, and

border.

Generic Field Properties - General Tab

Access this tab using Reports>Forms Designer>OK button>Insert Generic Field>

Properties.

Use this tab to select a system or organization-specific field to be added to the layout, such as System

Date or Organization Name. The Size and Position of the box/field on the layout can also be determined.



Generic Field Properties

After all selections are made, click OK, and the system applies the properties. These settings are saved

with the layout.

Fields

Select Generic Field: Select the field to display on the layout, such as System Date or Organization

Name.

The available fields are associated with the layout type selected on the Create New Layout form. Use the

drop-down list to see a list of available fields.

Size and Position: The system displays the size and position for the box on the layout, but its parameters

can be changed if needed.

Left, Top: Enter the number, in inches, for the system to place the box from the left and top edge of the

screen.

Width, Height: Enter the width and height of the box.

Tip: Use the ruler at the top of the screen to help assist in placing fields on the layout.

Generic Field Properties - Conditions Tab

Access this tab using Reports>Forms Designer>OK button>Insert Generic Field>

Properties.

Use this tab to select on which forms the field (that was selected on the General tab) appears.

Fields

Rules: Select a rule to apply to the forms—All Forms, Last Form, Overflow Forms, or First Form.

For example, if the detail data for the check does not fit on one page, the system continues printing the

data on as many pages as needed.

All Forms - The organization name, such as Social Service Agency, prints on every page of the check.

Last Form - The text prints only on the last page.

Overflow Forms - The text prints on all pages excluding the last page.

First Form - The text prints only on the first page.
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Generic Field Properties - Format Tab

Access this tab using Reports>Forms Designer>OK button>Insert Generic Field>

Properties.

Use this tab to format and align the text on the layout.

Fields

Format: Select how the box is formatted. For example, for four places after the decimal, select the

0.0000 format. If Default is selected as the format, current fields follow the formatting that was set up on

the Organization>Currency Setup form.

Alignment: Select where the characters appear in the box.

Horizontal: The system left-aligns, centers, or right-aligns the characters within the box, depending on

which option is selected.

Vertical: The system places the characters at the top, center, or bottom of the box, depending on

which option is selected. Vertical alignment only applies to unwrapped text. If the "Wrap Text" check

box is selected, the Vertical box is disabled.

Miscellaneous Wrap Text: Select this check box to automatically wrap the characters within the box.

Otherwise, some characters may be truncated, depending on the width of the box.

Generic Field Properties - Fonts & Borders Tab

Access this tab using Reports>Forms Designer>OK button>Insert Generic Field>

Properties.

Use this tab to change the Font of the text and the Background Color and Border of the box. When

applying a border, choose the width, style, and color.

Fields

Font: Click the Font button to change the font, style, and size of the text.



Table Properties

Back Color: Assign a color that fills the entire box. Click "Other" to customize a background color. (To

change the text color, click at the bottom of the Forms Designer.)

Style: Change the border style—None, Solid, Dash, Dot, DashDot, or DashDotDot.

Width: Change the border width. The width of the border can only be changed, if using a style of "Solid."

Color: Change the border color. Select "Other" to customize a border color.

Table Properties
Use this form to set up properties for the table on the Forms Designer form, such as the column names,

font, and heading height.

Table Properties - General Tab

Access this tab using Reports>Forms Designer>OK button>Insert Table> Properties.

Use this tab to select a Column Group for the table. The column group selected here determines the

column names available on the Detail tab. The Size and Position of the table on the layout can also be

determined.

After all selections are made, click OK, and the system applies the table properties. These settings are

saved with the layout.

Fields

Column Group: Select a column group, which determines the column names available for display on the

Detail tab of this form. The groups in the drop-down list are associated with the layout type selected on the

Create New Layout form.

For example, if A/P Checks is the layout type, select "Check Detail" from the drop-down list on this form.

Size and Position: The system displays the size and position for the table on the layout, but its

parameters can be changed if needed.

Left, Top: Enter the number, in inches, for the system to place the table from the left and top edge of the

screen.

Width, Height: Enter the width and height of the table.
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Tip: Use the ruler at the top of the screen to help assist in placing fields on the layout.

Table Properties - Heading Tab

Access this tab using Reports>Forms Designer>OK button>Insert Table> Properties.

Use this tab to format the column names for the table. You can add a border; underline and change the

font of the names; display vertical lines between the column names, and adjust the heading height.

Remove the check mark for Show Column Headings, to hide the column names on the layout.

Fields

Heading: Use this group box to format the column headings for the table. Click the Font button to change

the font, style, and size of the text. The system default is Arial, Regular, and 10 pt.

Border: Select this check box to add a border around the column names.

Underline: Select this check box to underline the column names.

Show Column Headings: Select this check box to display the column names in the table.

Vertical Lines: Select this check box to add vertical lines between the column names.

Heading Height: Enter, in inches, the cell height for the column names.

Table Properties - Detail Tab

Access this tab using Reports>Forms Designer>OK button>Insert Table> Properties.

Use this tab to set up properties for the detail data in the table. You can add a border, add

horizontal/vertical lines around the cells, adjust the row height, and change the font.

Fields

Detail: Use this group box to format the detail data in the table.

Border: Select this check box to add a border around the detail data in the table.

Horizontal Lines: Select this check box to add horizontal lines to separate the detail data in the table.

Vertical Lines: Select this check box to add vertical lines to separate the detail data in the table.



Drawing Properties

Autofit Row Height: Select this check box to allow the height of each row to be calculated

independently and will therefore accommodate for the printing of long charge code descriptions. If this is

selected, Row Height is not available, but Space Between Rows is available. This field only appears if

A/R Invoices was selected on the Create New Layout form.

Font: Click the Font button to change the font, style, and size of the text. The system default is Arial,

Regular, 10 pt.

Space Between Rows: Enter (in inches) how much space you want between the calculated rows. This

is only available if you selected Autofit Row Height and if you selected A/R Invoices on the General tab.

Row Height: Enter the row height (in inches) for the cells in the table. This is not available if Autofit Row

Height is selected.

Detail Table: Use this group box to adjust the heading names; enter the desired width of the columns; and

select the alignment and format of the text. Also select whether or not the columns display in the table.

Column Name: The system displays a list of available column names.

Heading: The system defaults to the "Column Name," but it can be changed. Enter the heading name of

the column to appear in the table.

Width: Enter the desired width of the column.

Show: Select this check box to display the column in the table. If the check box is not selected, the

column is hidden on the layout.

Align: Select the text alignment within the column—Left, Center, or Right.

Format: Select the format of the column. For example, for two places after the decimal, select the 0.00

format. If Default is selected as the format, current fields follow the formatting that was set up on the

Organization>Currency Setup form.

Tip: To change the order of the columns, select the column using the row selector (the left most column

in the table). Then, drag it using the mouse to the desired position in the table.

Drawing Properties
Use this form to set up properties for the drawing on the Forms Designer form, such as the type of line to

appear on the layout. Select a border style, color, and other items for the line drawing. For example, a box

may need to be added around the "Amount" field, or lines drawn to separate columns in the table.
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Drawing Properties - General Tab

Access this tab using Reports>Forms Designer>OK button>Insert Drawing> Properties.

Use this tab to select a Type of line drawing for the layout—horizontal line, vertical line, or box. The Size

and Position of the drawing on the layout can also be determined. After all selections are made, click OK,

and the system applies the drawing properties.

Fields

Type: Select a drawing type for the layout—horizontal line, vertical line, or box.

Size and Position: The system displays the size and position for the drawing on the layout, but its

parameters can be changed if needed.

Left, Top: Enter the number, in inches, for the system to place the drawing from the left and top edge

of the screen.

Width, Height: Enter the width and height of the drawing.

Tip: Use the ruler at the top of the screen to help assist in placing fields on the layout.

Drawing Properties - Conditions Tab

Access this tab using Reports>Forms Designer>OK button>Insert Drawing> Properties.

Use this tab to select on which forms the drawing (that was selected on the General tab) appears.

Fields

Rules: Select a rule to apply to the forms—All Forms, Last Form, Overflow Forms, or First Form.

For example, if the detail data for the check does not fit on one page, the system continues printing the

data on as many pages as needed.

All Forms - The drawing prints on every page of the check.

Last Form - The drawing prints only on the last page.



Picture Properties

Overflow Forms - The drawing prints on all pages excluding the last page.

First Form - The drawing prints only on the first page.

Drawing Properties - Format Tab

Access this tab using Reports>Forms Designer>OK button>Insert Drawing> Properties.

Use this tab to change the line Style, Width, and Color of the drawing. Fill Color only applies to a box

drawing. It fills the entire box with the appropriate color.

Fields

Style: Click the drop-down list to change the border style—Solid, Dash, Dot, DashDot, or DashDotDot.

Width: Click the drop-down list to change the border width. The drawing width can only be changed if

using the style "Solid."

Color: Click the drop-down list to change the color of the drawing. Click "Other" to customize a color.

Fill Color: Click the drop-down list to assign a background color to the box. Click "Other" to customize a

color.

Picture Properties
Use this form to set up properties for the picture on the Forms Designer form. Select a rule that the system

has created, or customize a rule using the Filter form on the Conditions tab. Use the Border tab to add a

border around the graphic.
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Picture Properties - General Tab

Access this tab using Reports>Forms Designer>OK button>Insert Picture> Properties.

Use this tab to add a graphic to the layout. For example, a company logo may need to be inserted on a

check or invoice. After all selections are made, click OK, and the system applies the properties to the

layout.

Note: Be sure to store a bitmap locally to restrict access to it (such as a signature).

Fields

Select Bitmap File: Click Browse and add the graphic to the layout. This graphic has to be a bitmap

(*.bmp). You cannot use a *.jpeg or a *.gif file.

Keep in mind that each time the template is used for printing, the program looks for the picture in the path

specified in this box. If the picture file has been moved or deleted, the picture will not appear on the

layout or on the printed form. We recommend storing the bitmap files in the Formats directory.

Display Picture in Original Size: Select this check box to display the graphic in its original size. If the

check box is not selected, the picture is resized to fit into the field on the layout.

Size and Position: The system displays the size and position for the graphic on the layout, but its

parameters can be changed if needed.

Left, Top: Enter the number, in inches, for the system to place the graphic from the left and top edge

of the screen.

Width, Height: Enter the width and height of the graphic.

Tips:
Use the ruler at the top of the screen to help assist in placing fields on the layout.

To resize the box to fit the size of the graphic: click the box and then use the resizing handles on the

corners and sides of the graphic.



Picture Properties

Adding a Signature using Forms Designer

Complete the following steps to add a signature to a check or any other document using the Forms

Designer:

1. Scan the signature and save the signature as a bitmap file (*.bmp).

2. After the layout has been created, click Insert Picture .

3. Double click in the box, and then the Picture Properties form displays.

4. Select the *.bmp file on the General tab.

5. Click OK, and then the signature displays on the layout.

Picture Properties - Conditions Tab

Access this tab using Reports>Forms Designer>OK button>Insert Picture> Properties.

Use this tab to select on which forms the graphic (that was selected on the General tab) appears.

Fields

Rules: Select a rule to apply to the forms—All Forms, Last Form, Overflow Forms, or First Form.

For example, if the detail data for the check does not fit on one page, the system continues printing the

data on as many pages as needed.

All Forms - The graphic prints on every page of the check. To print a company logo on every page,

select this rule.

Last Form - The graphic prints only on the last page.

Overflow Forms - The graphic prints on all pages excluding the last page.

First Form - The graphic prints only on the first page.

Additional Rules Make Rule: Click the Make Rule button to set up a new rule. The Filter form appears,

allowing you to narrow down and more explicitly, specify the data to include on the forms.

Once the selections are complete, click OK on the Filter form to apply the rule.
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Restricting Signature Usage

Restrict usage of the signature box in the Forms Designer by including a rule that restricts signature

printing based on the amount of the check. To do this:

1. Click the Make Rule button (on the Picture Properties>Conditions tab).

2. Move "Document Amount" to the selected filter.

3. Select < (Less Than) in the Compares To column.

4. Enter the amount in the Criteria 1 column.

5. Click OK.

Picture Properties - Border Tab

Access this tab using Reports>Forms Designer>OK button>Insert Picture> Properties.

Use this tab to change the border Style, Width, and Color of the box on the layout.

Fields

Style: Change the border style—None, Solid, Dash, Dot, DashDot, or DashDotDot.

Width: Change the border width. The border width can only be changed, if using a style of "Solid."

Color: Change the border color. Select "Other" to customize a border color.

MICR Properties
Use this form to set up properties for the MICR items on the Forms Designer layout.

MICR Properties - General Tab

Access this tab using Reports>Forms Designer>OK button>Insert MICR> Properties.

Use this tab to enter information on the layout, such as the bank routing number, account number, and

check number, so they will print on the check in the special font required by the bank. The Size and

Position of the MICR item can also be determined. After all selections are made, click OK, and the

system applies the MICR properties. These settings are saved with the layout.



MICR Properties

Note: If you intend to use the MICR font encoding, please contact your printer manufacturer about MICR

toner cartridges.

Fields

Display Information: Enter the proper letters to produce symbols, along with the routing and account

numbers. The information entered here, is what prints on the check. The letters must be entered in

capitals.

To display the check number, enter an "N." The system prints the check number starting with the number

entered on the following forms:

Activities>Check Writing>Write Checks>Transaction Entry

Activities>Accounts Payable>Pay Selected A/P Invoices>Load Checks/Vouchers

Activities>Payroll>Print/Email Checks and Vouchers>Load Checks/Vouchers

Size and Position: The system displays the size and position for the MICR item on the layout, but its

parameters can be changed if needed.

Left, Top: Enter the number, in inches, for the system to place the MICR item from the left and top edge

of the screen.

Width, Height: Enter the width and height of the MICR item.

Tip: Use the ruler at the top of the screen to help assist in placing fields on the layout.

Inserting MICR Code

When inserting MICR code (using Insert MICR on the Forms Designer), there are certain letters that

must be used in order to create the needed symbols. Furthermore, there is a specific format that must be

followed. We recommend consulting your bank for the format they require.

The machine language for MICR consists of 13 characters.

Ten Digits — 1 2 3 4 5 6 7 8 9 0

Three Symbols —

Enter the following on the keyboard to display the special characters required by the bank:
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MICR Properties - Conditions Tab

Access this tab using Reports>Forms Designer>OK button>Insert MICR> Properties.

Use this tab to select on which forms the MICR item (that was entered on the General tab) appears.

Fields

Rules: Select a rule to apply to the forms—All Forms, Last Form, Overflow Forms, or First Form.

For example, if the detail data for the check does not fit on one page, the system continues printing the

data on as many pages as needed.

All Forms - The MICR item prints on every page of the check.

Last Form - The MICR item prints only on the last page.

Overflow Forms - The MICR item prints on all pages excluding the last page.

First Form - The MICR item prints only on the first page.
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Index

A

accounts payable

creating custom forms 10

accounts receivable

creating custom forms 10

adding fields 13

amount restrictions 37-38

auto signed checks 36

C

cash receipts

creating custom forms 10

checks

adding graphics to 36

auto signed 36

creating custom forms 10

restricting signature printing 37-38

continuous forms 18

copying

forms designer layouts 20

creating custom forms 10

creating foreign currency formats 11

custom forms 10

customer statements

creating custom forms 10

D

designing forms 10

F

forms designer

aligning selections 13

copying layouts 20

creating custom forms 10

creating foreign currency formats 11

deleting selections 13

displaying grid lines 10

finding records 21

formatting text 13

hiding grid lines 10

importing formats 17

inserting drawings 13, 34

inserting fields 13, 24-25, 28

inserting lines 13, 34

inserting MICR items 13, 38

inserting pictures 13, 36

inserting tables 31



Index

inserting text 13, 23

layout properties 22

opening layouts 18

printing documents 7

saving layouts 19

selecting layouts 9, 18

selecting templates 20

templates and layouts 2

I

importing

forms designer formats 17

inserting fields 13

invoices

adding graphics to 36

creating custom forms 10

L

laser forms 18

M

MICR items 38

monetary restrictions 37-38

P

payroll

creating custom forms 10

printing

forms designer documents 7

properties

database fields 24-25

drawings 34

generic fields 28

layouts 22

MICR 38

pictures 36

tables 31

text 23

purchase orders

adding graphics to 36

creating custom forms 10

R

receipts

creating custom forms 10

restricting signature usage 37-38

S

signature printing 36-38

T

templates 2, 20

truncated text 24, 27, 30
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