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Chapter 1: Getting Started

This guide includes combined instructions for both New and Upgrade installations of MIP Fund

Accounting.

New Installation Scenarios

You are installing a one-user version of MIP (programs and database) on a single computer. The

computer may or may not be part of a network, but the programs and database reside on the local hard

drive of this computer. In this scenario, there are no network files involved, and no other computers

have access to the system/database. Optional, IIS Web Server running on the single computer or

separately if connected to your network.

You have a network comprised of a server machine with one or more local computers attached, and

you want to install the database on the server machine so that other users can access it from their local

computers (either one at a time or simultaneously depending on your license). Optional, IIS Web

Server running on separate server on your network.

You have a network comprised of two or more local computers that can access each other's shared

drives, and you want to install the database on one computer's shared drive so that other users can

access it from their local computers (either one at a time or simultaneously depending on your license).

Optional, IIS Web Server running on separate server on your network.

You have a network and want to install the database on a server machine for backup and security

purposes, even though only one user accesses it from a single local computer. Optional, IIS Web

Server running on separate server on your network.

You are installing the MIP programs and database in a virtual environment. You must use a virtual

service client, such as VMWare's Infrastructure Client Console, instead of a Remote Desktop

Connection. Optional, IIS Web Server running on a separate server within the virtual environment.

Upgrade Installation Scenarios

You are upgrading an existing Stand Alone or Network installation. Your installation will upgrade if you

have a previous version installed.

You are upgrading the MIP programs and database in a virtual environment. You must use a virtual

service client, such as VMWare's Infrastructure Client Console, instead of a Remote Desktop

Connection.
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For specific information regarding existing users, see "Existing User - Upgrading" (page 30), "Existing

User - Server Install" (page 34), and "Existing User - Workstation Install" (page 44).

Optional Alerts IIS Server Installation Scenarios

The Alerts installation will work with any of the above scenarios for Stand Alone or Network

installation. It is a common practice to have a separate IIS Web server as a part of your network so

that your SQL Server will not experience additional performance delays when processing transactions

or running reports.

If the IIS Web Server is installed on the same computer along with the MIP programs and database,

you could experience connection limitations and possible performance delays when processing

transactions and running reports.

If IIS Web Server is on a machine using a Windows 10 or 11 Operating System, the system has a 10

concurrent connection limitation. This is a known Microsoft restriction when using Windows 10 or 11

as the Alerts Server. It is recommended that you use a separate server on your network as your IIS

Web Server. Ideally, it could have an older server version Operating System running, such as

Windows Server 2016. Note that having a local machine with Windows 10 or 11 as an MIP workstation

will not cause any problems.

System Requirements
You should meet or exceed the MIP Accounting system requirements before you install the application.

Important! Microsoft .NET Core Runtime version 8.0.8 must be installed on the server and each

workstation prior to installing MIP v2025.4

Before You Begin

For optimum results, perform the following tasks on the workstation and server before running the

installation program:

1. Verify that your current environment meets the new system requirements.

Important! Microsoft .NET Core Runtime version 8.0.8 must be installed on the server and each

workstation prior to installing MIP v2025.4

https://www.mip.com/system-requirements/
https://www.mip.com/system-requirements/


Before You Begin

Important! Before installing or upgrading to the current software version, verify that you are a user

with Administrator rights on the SQL Server or have access to the SQL Server System Admin (SA)

password. Upon upgrade, the MIP software will be uninstalled. If you are not an Administrator on the

SQL Server nor have the SA password, you will not be able to install any version of the software.

2. Shut down all applications that are currently running, and restart the computer.

3. After Windows has restarted, shut down any applications that have opened at start-up and turn off the

User Account Controls. Additionally, you may need to disable some applications, such as Norton

AntiVirus©.

Press CTRL-ALT-DELETE to open the Windows Security form. Click the Task Manager button to

open the Windows Task Manager form. On the Applications tab, select each program listed in the

form, and click End Task.

Note: The above processes only shut down the applications for the purposes of the installation. The

next time the computer is rebooted, the programs and all Windows services are restored.

4. If the Windows Firewall is turned on, you must configure exceptions in the firewall for SQL Server or

the client computer(s) will not be able to connect. For specific instructions on setting up the exceptions,

see article 5156 in the Knowledgebase.

5. Delete all files in the local TEMP directory, such as C:\Documents and Settings\<Current User>\Local

Settings\Temp. Since the computer has just rebooted and any unnecessary applications are closed,

there should be few files in the Temp directory. Nevertheless, delete any files or folders that remain

there.

6. If you are running MIP on a laptop, set your hibernation settings to Never (Start>Settings>Control

Panel>Power Options>Power Schemes tab). Otherwise, when the computer times out, your seat will

become inactive.

7. Before you begin the server install:

The user logged on to the server machine must be a member of the Local Administrators group and

a user with Administrator rights on the SQL Server or have access to the SQL Server System

Admin (SA) password.

You must have Microsoft .NET Core Runtime version 8.0.8 installed. You can verify your .NET

version using Control Panel>Programs and Features.
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Important! If the .NET framework is not installed, the MIP Fund Accounting installation wizard

cannot continue. You must exit the wizard and restart it after you install the .NET Core Runtime

version 8.0.8 framework.

To install or upgrade MIP on a virtual environment, you must use a virtual service client, such as

VMWare's Infrastructure Client Console, instead of a Remote Desktop Connection.

SQL Server 2014 users: Be sure to start the SQL Server Browser and consider setting the Start

Mode to Automatic to ensure that the workstation can access the MIP system database.

Access the email sent to you by MIP which contains the link and download the MIP software to the

computer functioning as the MIP Accounting Server.

8. Before you begin the workstation install, you must ensure the following:

The user logged on to the server machine must be a member of the Local Administrators group.

Each workstation has at the very least read-write access to the “ProgramData” folder--<local drive

letter:>\ProgramData. Also verify that each user that uses Aatrix® (for 1099s, W-2s, 990s, 1095s,

etc.) has rights.

MIP cannot install successfully without these folders and rights.

9. Before you begin the Alerts Setup install, verify that the following are installed:

Internet Information Server (IIS) 10 must be installed on the web server. The MIP Accounting

Alerts installation will attempt to install IIS if it is not already installed.

10. Close any open windows.

After performing these steps, you are ready to run the Installation program.
The Getting Started guide assists in setting up the chart of accounts once the system is successfully

installed, and Help is always available at the click of a button in the context-sensitive online help system.



Chapter 2: New User - Server Install

This chapter describes the installation process for a stand-alone, virtual, or network server. You must

select a database engine prior to installing the MIP Accounting Server. Once you have completed these

steps, follow the instructions in New User - Workstation Install to install the workstation.

This chapter explains the following:

"Server Install Overview" (page 34)

"Local Server Configuration" (page 6)

"Directory Structure Overview" (page 35)

"SQL Server (Express Download)" (page 9)

"MIP Accounting Server Install" (page 10)

"Granting Access to the MIP Share Directory" (page 17)

Server Install Overview
The Server install is comprised of the following:

SQL Server Express- Download Microsoft SQL Server 2019 Express with Advanced Services from

the SQL Server Express Installation link on the Setup tab of the MIP Accounting Install on the MIP

Accounting AutoRun.exe, or use an already installed version of Microsoft SQL Server 2016 (Full

Version), SQL Server 2017 (Full Version), or SQL Server 2019.

MIP Accounting Server - The MIP Accounting Server installation creates the MIP Share directory. We

recommend accepting the default path when installing the server component.

The necessary files related to the MIP Accounting Server Install are copied to the SQL server. To

download the Microsoft SQL Server 2019 Express Edition with Advanced Services from the Microsoft

website, click the SQL Server Express Installation link that displays on the Setup tab of the MIP

Accounting Install on the MIP Accounting AutoRun.exe.

Important! Microsoft .NET Core Runtime version 8.0.8 must be installed on the server and each

workstation prior to installing MIP v2025.4
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Important! Before installing the software, verify that you are a user with Administrator rights on the

SQL Server or have access to the SQL Server System Admin (SA) password. Otherwise, you will not

be able to install the software.

Local Server Configuration
In order to successfully install and run MIP on a stand-alone machine, verify that the File and Printer

Sharing Service is installed, the TCP/IP protocol is installed, and the Server Service is enabled. Then,

you need to complete the instructions in this chapter to ensure that the MIP Accounting Server is

installed correctly. Once you have completed these steps, follow the instructions in New User -

Workstation Install to install the workstation.

Note: If you do not have a network adapter driver installed, you cannot continue the MIP install. You

need to install the Microsoft Loopback Adapter first (follow the instructions below).

To Activate File and Printer Sharing Service:

1. Right-click Network and then select Properties. The Network and Sharing Center displays.

2. Under Sharing and Discovery, verify that File Sharing and Printer sharing are listed as On.

3. If Off displays, expand the down arrow and select the Turn on option.

To Enable the Server Service:

1. Go to Start>Settings>Control Panel>Administrative Tools>Services.

2. Double-click the Server Manager.

3. Expand Configuration, and click Services.

4. Make sure that the Startup type is Automatic and the Server Status is Started. If those settings are

not in place, implement them, and then click OK.

To Install TCP/IP:

1. Right-click Network and then select Properties.

2. Click View Status for Local Area Connection and then click Properties.

3. If Internet Protocol Version 4 or 6 (TCP/IPv4/v6) is not selected in the list, check the box and click the
Install button. If it is listed, click OK and skip to step 6.

4. Select Protocol, and then click Add.



Directory Structure Overview

5. Select Internet Protocol (TCP/IP), and then click OK.

6. Click Close to close the Local Area Connection Status window.

Note: If you are actually using TCP/IP to connect to your network, make sure that it is configured

properly.

Directory Structure Overview
The MIP Accounting Server executable (SETUP.EXE) creates the MIP Share directory. We recommend

accepting the default path when installing the server component.

Data Files and Directory Structure

When installing the MIP Accounting Server, the data files and workstation share files are stored on the

machine that is functioning as the server. The workstation installation stores the MIP system and program

files on each client machine.

After the server installation, the following directory structure exists on the drive and in the directory that

was specified during installation.

MIP Fund Accounting

Installation Guide

7



Chapter 2: New User - Server Install

MIP Fund Accounting

Installation Guide

8

MIP Share Directory

Note: Do not Password Protect the MIP Share Directory.

This directory contains the following folders:

AATRIX contains the drafts and historical forms created by Aatrix, for each federal tax ID in the

Companies folder.

CONSOLIDATION FILES contains CONTEMP.TXT, which will be altered when consolidating data.

DATA contains a copy of the NPSSQLSYS.NPS and NTO.NPS files. These are the system and

sample database files that come with the system.

DDEPOSIT contains ACH.TXT, which will be altered when using the Direct Deposit module.

EPAYAP contains ACHAP.TXT, which will be altered when using the Electronic Funds Transfer for

A/P module.

FORMATS contain the files needed to print custom forms in the system. This is where you should

store custom formats created by the Forms Designer module.

GRANTADMIN contains scanned images of sample grant documentation for the Grant Administration

module.

IMPORT includes sample DEF and data files that can be used with the Data Import/Export module.

LOG contains ABILALOGACCT.LOG, ABILALOGADMIN.LOG, and ABILALOGPAYROLL.LOG files

that document when an error occurs related to the Alerts module, such as, failure to connect to the

Alert Server.

MIP DOCUMENTATION includes the product guides available in PDF format.

{ORGANIZATION DATABASE NAME} contains all folders for attachments. This folder is not actually

created until the attachments feature is activated in the system (Organization>Attachments>Set Up

Locations).

REPORT PDF FILES contains *.PDF files saved while using the Print to PDF feature.

SETUP contains the files necessary to run the MIP Accounting Workstation installation. Each of the

client machines will need to access this folder in order to install the Workstation component. The

SETUP.EXE file launches the MIP Accounting Workstation installation.



SQL Server (Express Download)

SQLSCRIPTS contains SQL scripts necessary for the system to function properly.

SUPPORT contains support related folders.

SQL Server (Express Download)
Select one of the following that best describes your current setup, and then follow the instructions below

for installation:

SQL Server Express (can be downloaded by following in-product links) - If you do not already have

SQL installed, Microsoft SQL Server 2019 Express Edition with Advanced Services can be downloaded

from the SQL Server Express Installation link on your MIP Accounting Version 2025.x Setup tab.

SQL 2016, 2017, 2019, 2022, or SQL Express (already installed) - If either the Microsoft SQL Server

or SQL Express has already been installed as your server, proceed to the MIP Fund Accounting Server

Install instructions on the next page.

The SQL installation creates the \Program Files\Microsoft SQL Server directory. By default, this directory

is located on the local drive in which your operating system is installed. Use the browser to change this

destination during the installation.

All users have the option to install their own instance of SQL Express or SQL Server. This gives you the

ability to administer it according to your practices.

SQL Server Express (Can be downloaded by following a link)

This section describes the installation process for the Microsoft SQL Server 2016 Express Edition with

Advanced Services from the MIP Accounting Version 2025.x Setup Tab. Please carefully read each panel

of the wizard during installation.

Important! Before you begin, verify that Microsoft .NET Core Runtime version 8.0.8 or higher is installed

before you try to Install MIP Accounting Server. Go to Start>Settings>Control Panel>Programs and

Features.

1. Download the MIP software to the computer functioning as the MIP Accounting Server. To get the

latest download, see the Knowledgebase.

Once complete, the system automatically launches autorun.exe and the Abila MIP Accounting Setup

window displays.

MIP Fund Accounting
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2. Select SQL Server Express Installation and follow the steps to download SQL Server Express from

the Microsoft website. Upon completion, be sure to install the SQL Server's latest service pack

updates before continuing the installation process.

Note: Click here to open a browser to access instructions for installing the SQL Server 2016

Express on the Knowledgebase.

MIP Accounting Server Install
When installing the MIP Accounting Server, a directory is created by default—<Server Name>:\MIP

SHARE. The MIP Accounting Server must be installed before proceeding to the "MIP Accounting

Workstation Install" (page 20).

Note: To install or upgrade in a virtual environment, you must use a virtual service client, such as

VMWare's Infrastructure Client Console, instead of a Remote Desktop Connection.

Please carefully read each panel of the wizard during installation.

https://kb.communitybrands.com/article/how-install-microsoft-sql-express-2016


MIP Accounting Server Install

1. Be sure you are logged in as a user who has local administrator rights to perform the install. Also,

verify that you are a user with Administrator rights on the SQL Server or have access to the SQL

Server System Admin (SA) password. (If you are not an Administrator on the SQL Server nor have the

SA password, you will not be able to install the software.)

2. If you have not already done so, download the MIP software to the computer functioning as the MIP

Accounting Server.

The system automatically launches autorun.exe and the Abila MIP Accounting Setup window displays.

3. After reviewing the provided documentation, select the Begin Installation Process option. The system

begins extracting the setup.exe file.

4. The Abila MIP Accounting Server InstallShield Wizard prepares to install. The Welcome panel

displays. Click Next.
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”

option to continue with the Server Installation.

6. Click Next. The system displays the Product Registration panel. Enter the Serial Number and

Activation Code.

The activation code is case sensitive, so it must be entered exactly as it appears on the notification

included with the system. (Store the activation code in a safe place in case your system needs to

be reinstalled.)



MIP Accounting Server Install

Activation

Codes

The activation code is determined by the system’s license. The system uses the

activation code to determine which modules you own, how many additional

databases you have purchased, and how many concurrent users you will have

available. Later, if you decide to add a module or increase your users or databases,

you need to enter a new activation code. To enter a new license, with Administrative

user rights open the System>Activate License form. To add a module to an existing

database, use the Organization>Add A Module form.

7. Click Next. Accept the default MIP Share destination folder (recommended), or use the Change button

to navigate to a different location.
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8. Click Next. Select the database server that you are installing to by using the drop-down arrow, or

Browse to the database location.

Then, select how you want to connect to this server. If Server authentication is chosen, enter the

Login ID and Password.

9. Click Next. You are now ready to Install MIP Accounting.

10. Click Install to begin, or use the Back button to make changes.

11. Proceed through the MIP Server setup. This process may take several minutes.

12. When the installation is complete, the InstallShield Wizard Completed panel displays.



MIP Accounting Server Install

This is the final panel of the server installation. It verifies that the MIP Accounting Server installed

successfully.

Select the “Install MIP Workstation” check box, and then click Finish to continue through the

installation program by launching the MIP Accounting Workstation Installation wizard. For

instructions, proceed to New User - Workstation Install.

Alternatively, if you do not select the check box, you can install later from the MIP Share directory.

For more information, see "Granting Access to the MIP Share Directory" (page 17).

Optional, install Alerts on your IIS Web Server. For more information, see "Alerts Install" (page 56)

13. Click Finish to complete the install.

14. If applicable, click the Exit button on the MIP Accounting Installation Startup form.

15. Navigate to the MIP Share directory on the Server and set it to share with Full control permissions to

Everyone.

Troubleshooting

You may not be able to install because of an error from the "Windows Installer Coordinator". The Windows

Installer Coordinator may get stuck or fail during an install or update.
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If this Windows Installer Coordinator error appears, you must disable the Windows Installer

RDS compatibility.

1. Open the Windows "Run" function by pressing the Windows key + R, or typing "run" into the

Windows search bar.

2. Run "GPEDIT.MSC".

3. The Local Group Policy Editor will display. Open the "Administrative Templates" subfolder located

under the "Computer Configuration" heading.

4. Open the "Windows Components" folder.

5. Open the "Remote Desktop Services" folder.

6. Open the "Remote Desktop Session Host" folder.

7. Open the "Application Compatibility" folder.

8. Select "Turn off Windows installer RDS compatibility" by double clicking.

9. Set this feature to "Enabled".



Granting Access to the MIP Share Directory

10. Proceed with the MIP installation.

Granting Access to the MIP Share Directory
The MIP Share directory (which the Server installation created) contains the files necessary to install

MIP's program files at each workstation. First, the MIP Share directory must be shared so that the

workstations will have access to it.

1. Right-click the MIP Share directory at the server and select Share. . . If you do not see Shared, you

will need to log on as a user account that is a member of the Local Administrators or Power Users

group.

2. On the Sharing tab, click Advanced Sharing. And then select the Share this folder check box.

3. Click the Permissions button.

4. Add the desired users/groups.

Note: If you share to specific users/groups and not the “Everyone” group, you will need to add the

“System” account with full rights on the Security tab. If you give the “Everyone” group full rights, then

it is not necessary to add “System.”

5. Grant each user/group Full Control and click OK. A minimum of Change and Read permissions are

required. NTFS formatted servers will display a Security tab, in which case you must grant NTFS

Permissions. You need to allow System with Full Control.
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6. Click OK to close the Advanced Sharing window.

7. Click the Security tab.

8. Add the desired users/groups. Typically, the default NTFS permission is all you will need. However,

you can grant the users/groups Full Control access.

9. Click OK to apply these settings.

10. Click Close to close the MIP Share Properties window.

Note: You must allow inheritable permissions.



Chapter 3: New User - Workstation Install

Before starting the Workstation installation, you must have already completed the "MIP Accounting

Server Install" (page 10)and "Granting Access to the MIP Share Directory" (page 17), if there is a

network.

This chapter describes the installation process for the MIP Accounting Workstation. This installation

provides the program files needed to run the system (the MIP Fund Accounting shortcut and executable

files). You can choose which modules to install on the system. Please carefully read each panel of the

wizard during installation.

The necessary files related to this installation are copied to the MIP Share directory of the server during

the MIP Accounting Server installation. There is only one executable (SETUP.EXE) for the workstation

install.

Important! Be sure to run SETUP.EXE as an administator.

Note: The user logged on to the workstation machine must be a member of the Local Administrators

group.

Ensuring Access to “All Users” Folder
Before you begin the workstation install, you must ensure that the workstation has access to the “All

Users” directory. The following steps should be completed:

1. Click Start>Run.

2. Enter the <local drive letter:> in the Open box.

3. Click OK. The system displays an explore window.

4. Open the Program Data folder. If you do not see the folder, go to the "View" tab on the upper left

corner of the file explorer window, then check the "Hidden items" checkbox to reveal the hidden

Program Data folder.

5. Ensure that the “All Users” and <user name> folders are listed. Also verify that each user that uses

Aatrix® (for 1099s, W-2s, 990s, etc.) has “Full Control” rights (right-click on

folder>Properties>Security tab). MIP Accounting cannot install successfully without these folders and

rights. These steps should be completed for each workstation running on Windows 10 or 11.
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Data Files and Directory Structure
When installing the MIP Accounting Workstation, the system and program files are stored on each

computer. After the workstation installation, the following directory structure exists on the drive and in the

directory that was specified during installation.

MIP Directory

The MIP Accounting Workstation installation creates a MIP directory on the local disk partition with the

most space. This directory contains the following folders:

HELP contains all the files associated with the online help system.

PROGS contains the executable (*.EXE) files required to run the system. Specific *.DLL files are

included in the PROGS directory. Do NOT delete any of these files.

MIP Accounting Workstation Install
This section describes the workstation install. There are two ways to access this install:

If you selected the Install MIP Workstation check box at the end of the Server Install, the system

automatically launches the Welcome panel of the MIP Accounting Workstation install.

If you are installing the workstation only, go to the workstation machine and log on as a user with local

administrator rights. Navigate to the MIP Share directory (\\MIP Share) on the Server, open the Setup

sub directory, and select Setup.exe.



MIP Accounting Workstation Install

1. The Abila MIP Accounting Workstation install Welcome panel displays.

2. Click Next. Review the End User License Agreement and select the “I accept the terms in the license

agreement” option.

3. Click Next. Accept the default MIP destination folder (recommended), or use the Change button to

navigate to a different location.
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4. Click Next. The Custom Setup panel displays, which allows you to select the systems you would like

to install. By default, the system installs the start menu shortcuts and program files for all systems,

even if they are not part of the license.

To prevent a system from being installed, ensure that the “X” (Entire feature will be unavailable) is

selected. This designation prevents the installation of the program files and the start menu shortcuts

for that system. You may find this useful when you need to restrict a user from launching a specific

system.



MIP Accounting Workstation Install

Note: If you do not install all systems now, but later decide you want to install the program files or

start menu shortcuts, you can do so using Start>Settings>Control Panel>Add or Remove Programs.

Select MIP Workstation and the Change button. The system displays the Welcome panel of the

Install wizard. Click Next. Then, on the Program Maintenance panel, select the Modify option button,

followed by the Next button.

5. Click Next. The Install Wizard is ready to install the program.

6. Click Install to begin the installation, or click Back to make changes to your installation settings.

7. Proceed through the MIP Accounting Workstation setup. This process may take several minutes. The

InstallShield Wizard Completed panel displays.
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8. Click Continue to complete the Workstation Install.

9. Additional installs launch after you click Continue to complete the Workstation Install. Allow any

additional installs to complete, and then click OK on the “Your install completed successfully”

window message.

10. This is the final window of the workstation installation. It verifies that the MIP Accounting Workstation

installed successfully.

Optional, install Alerts on your IIS Web Server. For more information, see "Alerts Install" (page 56)

If applicable, click the Exit button on the MIP Accounting Installation Setup form.

At the end of the Workstation install, reboot your computer only if prompted to do so.

Note: Remember, a workstation installation must be performed on each workstation that needs to run

MIP Accounting.
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Troubleshooting

You may not be able to install because of an error from the "Windows Installer Coordinator". The Windows

Installer Coordinator may get stuck or fail during an install or update.

If this Windows Installer Coordinator error appears, you must disable the Windows Installer

RDS compatibility.

1. Open the Windows "Run" function by pressing the Windows key + R, or typing "run" into the Windows

search bar.

2. Run "GPEDIT.MSC".

3. The Local Group Policy Editor will display. Open the "Administrative Templates" subfolder located

under the "Computer Configuration" heading.
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4. Open the "Windows Components" folder.

5. Open the "Remote Desktop Services" folder.

6. Open the "Remote Desktop Session Host" folder.

7. Open the "Application Compatibility" folder.

8. Select "Turn off Windows installer RDS compatibility" by double clicking.

9. Set this feature to "Enabled".

10. Proceed with the MIP installation.

New User Workstation Update Tool Install
This section describes the Workstation Update Tool installation. The Workstation Update Tool is

bundled into the MIP workstation installation,

1. After the workstation installation is complete, the Abila MIP Accounting Workstation Update Tool

install Welcome Panel displays.



New User Workstation Update Tool Install

2. Click Next. Select the trusted user group for the install. This defaults to "Users".

3. Click Next. On the following screen, click Install
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.

4. At the end of the installation, click Finish.

Once you've installed the Workstation Update Tool, you can use the tool to easily download the latest

version of MIP Accounting.

Note: If your organization is hosted on the MIP Cloud (single-tenant AND multi-tenant organizations),

the Support team will set up and manage the Workstation Update Tool for you. No action is required on

your part.



New User Workstation Update Tool Install

Important! Please note that the Workstation Update Tool only provides workstation updates, not server

updates. Follow the instructions in Existing User - Server Install to update the organizational database

on a server from a previous version.
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This chapter provides information that only existing users might need. It explains:

"Upgrading from a Previous Version" (page 30)

"Changing Your Database Engine" (page 31)

"Updating Your Organization Database to Version 2025.4" (page 31)

"Activating Your License" (page 32)

"Adding a Module to an Organization" (page 32)

"Setting Up Security" (page 33)

Upgrading from a Previous Version
You can only upgrade your program files to version 2025.x from versions 2021.x through 2019.2. If you

are not currently running one of these versions, you must upgrade to one of them before you can upgrade

the application files to 2025.x.

Important! Microsoft .NET Core Runtime version 8.0.8 must be installed on the server and each

workstation prior to installing MIP v2025.4

Important! Before upgrading to the current software version, verify that you are a user with

Administrator rights on the SQL Server or have access to the SQL Server System Admin (SA)

password. Upon upgrade, the MIP software will be uninstalled. If you are not an Administrator on the

SQL Server nor have the SA password, you will not be able to install any version of the software.

1. Follow the instructions in Existing User - Server Install to upgrade the organizational database on a

server from a previous version.

2. Once you have installed the MIP Accounting Server, you will need to install the workstation.

Open the setup.exe from the \\MIP Share\Setup directory on your server, to launch the "MIP

Accounting Workstation Install" (page 46).

If the MIP Accounting Workstation component is already installed on the server or you wish to

install the Workstation on the server for the first time, you will need to open the application on the

server to complete the upgrade process before proceeding to the next step.
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3. Follow the instructions in Existing User - Workstation Install, to upgrade each user’s workstation.

If you have already installed the MIP Workstation on your machine, you can run the Workstation

Update Tool to easily upgrade your workstation to the latest version of MIP Accounting. For more

information, see the MIP Fund Accounting Workstation Update section of this guide. If your

organization is hosted on the MIP Cloud (single-tenant AND multi-tenant organizations), the MIP

Support team will set up and manage the Workstation Update Tool for you. No action is required

on your part.

4. Finally, follow the instructions to complete the Alerts installation on your IIS Web Server.

Changing Your Database Engine
If you are upgrading and moving your database to a different instance of SQL Express or SQL Server,

back up your system and organization databases, and then uninstall MIP and your current instance of

SQL.

After you complete the installation process, restore your system database, NPSSQLSYS, along with

your organization database. For specific instructions on uninstalling, see "Uninstalling MIP Accounting"

(page 62) and see "Supplemental Maintenance" (page 65) for instructions on backing up and restoring a

database.

For specific instructions on moving the MIP Accounting Server to a new server/computer, see article 876

in the Knowledgebase.

Updating Your Organization Database to Version 2025.4
You can only update your organization database after the server and workstation have been upgraded to

version 2025.4. To do so:

1. Log on to any system (Start>Programs>Abila>MIP Fund Accounting), and select an Organization.

2. The system displays a message stating that the organization database must be updated to the

current version.

Select Yes, to begin the backup process to back up your organization database and then upgrade
it. This is strongly recommended.

Select No, if you have a current backup of the database and want to begin the update process
immediately.

3. A utility program runs. Click Finish.

http://kb.communitybrands.com/node/876
http://kb.communitybrands.com/node/876
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4. When complete, a message displays informing you that your database has been updated

successfully.

5. Click OK.

Activating Your License
When you initially purchase the system, an activation code that activates any and all modules that have

been purchased is included with the software. You are prompted to enter that code during installation, and

do not need to enter it any other time. However, if you are currently using the system and decide to add a

module (or add users or databases), a new activation code will be sent to you.

Enter the new code in the system in order to use the new features:

1. Open the System>Activate License form.

2. On the Owned tab (or Evaluation tab if evaluating a new module), enter the new activation code. Note

that the activation code is case sensitive, so it must be entered exactly as it appears on the notification.

3. Click OK, and then the new features are registered in the system.

4. Exit the system (File>Exit), and then reopen it.

Note: If you were evaluating or adding the Scheduler module, and you did not include the program files

and start menu shortcut, you can do so now. Click Start>Settings>Control Panel>Add or Remove

Programs. Select MIP Accounting Workstation and the Change button. The system displays the

Welcome panel of the Install wizard. Click Next. Then, on the Program Maintenance panel, select the

Modify option button, followed by the Next button.

Adding a Module to an Organization
A module can be added to the current organization, but first ensure that there are no users currently

logged on to the system.

Note: The activation code must be changed (MIP Fund Accounting>System>Activate License) to

include Scheduler, Electronic Requisitions, and Payroll modules before these modules can be added.

To add a module:

1. Open the MIP Fund Accounting>System>Current Activity form to ensure that no one (except

yourself) is currently using the organization being updated.

2. Open the organization (File>Open Organization) in which to add the module.
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3. Open the Organization>Add a Module wizard. On the first panel, select the module to add by

selecting the appropriate check box.

4. Follow the instructions on the screen and continue through the wizard.

5. Click Finish, and then the system adds the designated module to the current organization. This

process may take several minutes.

6. To add a module to another organization, repeat this process.

Note: For more information about the Add a Module wizard, see the online help or the Administration
guide.

Setting Up Security
User security needs to be set up for each new module. To do so:

1. Open the Security>Set Up Organization Menus form to grant rights to users. This includes granting

rights to new menu selections that are part of the new module.

2. Remember, this process must be repeated for each separate organization in which the module was

added and requires exclusive access to the system database.

Note: For more information about the Set Up Organization Menus form, see the online help or the

Administration guide.
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This chapter describes the installation process for a stand-alone or network server. Prior to upgrading the

MIP Accounting Server Install, you must close all workstations. Once you have completed the steps in

this chapter, follow the instructions in Existing User - Workstation Install to install the workstation.

This chapter explains the following:

"Server Install Overview" (page 34)

"Directory Structure Overview" (page 35)

"SQL Server Install " (page 36)

"MIP Accounting Server Install" (page 38)

Server Install Overview
The Server install is comprised of the following:

SQL Server Express- Download Microsoft SQL Server 2019 Express with Advanced Services from

the SQL Server Express Installation link on the Setup tab of the MIP Accounting Install on the MIP

Accounting AutoRun.exe, or use an already installed version of Microsoft SQL Server 2016 (Full

Version), SQL Server 2017 (Full Version), or SQL Server 2019.

MIP Accounting Server - The MIP Accounting Server installation creates the MIP Share directory. We

recommend accepting the default path when installing the server component.

The necessary files related to the MIP Accounting Server Install are copied to the SQL server. To

download the Microsoft SQL Server 2019 Express Edition with Advanced Services from the Microsoft

website, click the SQL Server Express Installation link that displays on the Setup tab of the MIP

Accounting Install on the MIP Accounting AutoRun.exe.

Important! Microsoft .NET Core Runtime version 8.0.8 must be installed on the server and each

workstation prior to installing MIP v2025.4

Important! Before installing the software, verify that you are a user with Administrator rights on the

SQL Server or have access to the SQL Server System Admin (SA) password. Otherwise, you will not

be able to install the software.
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Directory Structure Overview
The MIP Accounting Server executable (SETUP.EXE) creates the MIP Share directory. We recommend

accepting the default path when installing the server component.

Data Files and Directory Structure

When installing the MIP Accounting Server, the data files and workstation share files are stored on the

machine that is functioning as the server. The workstation installation stores the MIP system and

program files on each client machine.

After the server installation, the following directory structure exists on the drive and in the directory that

was specified during installation.

MIP Share Directory

Note: Do not Password Protect the MIP Share Directory.

This directory contains the following folders:

AATRIX contains the drafts and historical forms created by Aatrix, for each federal tax ID in the

Companies folder.

CONSOLIDATION FILES contains CONTEMP.TXT, which will be altered when consolidating data.



SQL Server Install

DATA contains a copy of the NPSSQLSYS.NPS and NTO.NPS files. These are the system and sample

database files that come with the system.

DDEPOSIT contains ACH.TXT, which will be altered when using the Direct Deposit module.

EPAYAP contains ACHAP.TXT, which will be altered when using the Electronic Funds Transfer for A/P

module.

FORMATS contain the files needed to print custom forms in the system. This is where you should store

custom formats created by the Forms Designer module.

GRANTADMIN contains scanned images of sample grant documentation for the Grant Administration

module.

IMPORT includes sample DEF and data files that can be used with the Data Import/Export module.

LOG contains ABILALOGACCT.LOG, ABILALOGADMIN.LOG, and ABILALOGPAYROLL.LOG files

that document when an error occurs related to the Alerts module, such as, failure to connect to the Alert

Server.

MIP DOCUMENTATION includes the product guides available in PDF format.

{ORGANIZATION DATABASE NAME} contains all folders for attachments. This folder is not actually

created until the attachments feature is activated in the system (Organization>Attachments>Set Up

Locations).

REPORT PDF FILES contains *.PDF files saved while using the Print to PDF feature.

SETUP contains the files necessary to run the MIP Accounting Workstation installation. Each of the

client machines will need to access this folder in order to install the Workstation component. The

SETUP.EXE file launches the MIP Accounting Workstation installation.

SQLSCRIPTS contains SQL scripts necessary for the system to function properly.

SUPPORT contains support related folders.

SQL Server Install

Important! Microsoft .NET Core Runtime version 8.0.8 must be installed on the server and each

workstation prior to installing MIP v2025.4

Select one of the following that best describes your current setup, and then follow the instructions below

for installation:
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SQL Server Express (can be downloaded by following a link on the AutoRun.exe) - If you do not

already have SQL installed, Microsoft SQL Server 2019 Express Edition with Advanced Services can

be downloaded from the SQL Server Express Installation link on the MIP AutoRun.exe.

SQL 2016, SQL 2017, SQL 2019, SQL Express (already installed) - If either the Microsoft SQL

Server or SQL Express has already been installed as your server, proceed to the MIP Fund

Accounting Server Install instructions on the next page

The SQL installation creates the \Program Files\Microsoft SQL Server directory. By default, this directory

is located on the local drive in which your operating system is installed. Use the browser to change this

destination during the installation.

Important! Before installing the software, verify that you are a user with Administrator rights on the

SQL Server or have access to the SQL Server System Admin (SA) password. Otherwise, you will not

be able to install the software.

All users have the option to install their own instance of SQL Express or SQL Server. This gives you the

ability to administer it according to your practices.

SQL Server (Express Downloaded)

This section describes the download process for the Microsoft SQL Server 2019 Express Edition with

Advanced Services from the MIP AutoRun.exe. Please carefully read each panel of the wizard during

installation.

Important! Before you begin, verify that Microsoft .NET Core Runtime version 8.0.8 or higher is

installed before you try to Install MIP Server. Go to Start>Settings>Control Panel> Programs and

Features.

1. On the computer functioning as the MIP Server, log on as a user with local administrator rights.

Note: With the release of version 2016.2, the Auto Update program was discontinued and was

uninstalled during that MIP installation process.

2. Download and extract the latest MIP software updates to the computer functioning as the MIP MIP

Server. To get the latest download, see the Knowledgebase.

https://kb.communitybrands.com/
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Important! Before upgrading to the current software version, verify that you are a user with

Administrator rights on the SQL Server or have access to the SQL Server System Admin (SA)

password. Upon upgrade, the MIP software will be uninstalled. If you are not an Administrator on the

SQL Server nor have the SA password, you will not be able to install any version of the software.

Once the download is complete, the system automatically launches autorun.exe and the MIP Setup

window displays.

3. Select SQL Server Express Installation and follow the steps to download SQL Server Express from the

Microsoft website. Upon completion, be sure to install the SQL Server's latest service pack updates

before continuing the installation process.

Note: Click here to open a browser to access instructions for installing the SQL Server 2016 Express

on the Knowledgebase.

MIP Accounting Server Install
This section describes the install process by continuing to use your existing database server.

The MIP Server must be upgraded before proceeding to the "Existing User - Workstation Install" (page

44). It is very important to perform a backup of your database before performing the upgrade.

Please carefully read each panel of the wizard during installation.

MIP Fund Accounting

Installation Guide

38

https://kb.communitybrands.com/article/how-install-microsoft-sql-express-2016


Chapter 5: Existing User - Server Install

MIP Fund Accounting

Installation Guide

39

Note: To install or upgrade in a virtual environment, you must use a virtual service client, such as

VMWare's Infrastructure Client Console, instead of a Remote Desktop Connection.

1. On the computer functioning as the MIP Server and log on as a user with local administrator rights.

Important! Before upgrading to the current software version, verify that you are a user with

Administrator rights on the SQL Server or have access to the SQL Server System Admin (SA)

password. Upon upgrade, the MIP software will be uninstalled. If you are not an Administrator on

the SQL Server nor have the SA password, you will not be able to install any version of the

software.

2. If you have not already done so, download and extract the latest MIP Accounting software to the

computer functioning as the MIP Server. To get the latest download, see the Knowledgebase.

3. Once complete, the system automatically launches autorun.exe and the MIP Accounting Setup

window displays. After reviewing the provided documentation, select the Begin Installation Process

option.

The system begins extracting the setup.exe file.

4. The Abila MIP Accounting Server InstallShield Wizard prepares to install. The Welcome panel

displays. Click Next.

https://kb.communitybrands.com/
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”

option to continue with the Server Installation.

6. Click Next. You are now ready to Install MIP Accounting.

7. Click Install to begin, or use the Back button to make changes.

MIP Fund Accounting

Installation Guide

40



Chapter 5: Existing User - Server Install

MIP Fund Accounting

Installation Guide

41

8. The system begins upgrading the MIP Accounting Server software. This process may take several

minutes.

9. When the upgrade is complete, the InstallShield Wizard Completed panel displays.

This is the final panel of the server installation. It verifies that the MIP Accounting Server installed

successfully.

Select the “Install MIP Workstation” check box, and then click Finish to continue through the

installation program by launching the MIP Accounting Workstation Installation wizard. For

instructions, proceed to "Existing User - Workstation Install" (page 44).



MIP Accounting Server Install

Alternatively, if you do not select the check box, you can install later from the MIP Share directory.

For more information, see "Granting Access to the MIP Share Directory" (page 17).

Optional, install Alerts on your IIS Web Server. For more information, see "Alerts Install" (page 56)

10. Click Finish to complete the install.

11. If applicable, click the Exit button on the MIP Accounting Installation Startup form.

12. Navigate to the MIP Share directory on the Server and set it to share with Full control permissions to

Everyone.

Note: Reboot your computer only if prompted to do so.

Troubleshooting

You may not be able to install because of an error from the "Windows Installer Coordinator". The Windows

Installer Coordinator may get stuck or fail during an install or update.

If this Windows Installer Coordinator error appears, you must disable the Windows Installer

RDS compatibility.

1. Open the Windows "Run" function by pressing the Windows key + R, or typing "run" into the Windows

search bar.

2. Run "GPEDIT.MSC".
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3. The Local Group Policy Editor will display. Open the "Administrative Templates" subfolder located

under the "Computer Configuration" heading.

4. Open the "Windows Components" folder.

5. Open the "Remote Desktop Services" folder.

6. Open the "Remote Desktop Session Host" folder.

7. Open the "Application Compatibility" folder.

8. Select "Turn off Windows installer RDS compatibility" by double clicking.

9. Set this feature to "Enabled".

10. Proceed with the MIP installation.
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Before starting the Workstation Installation, you must have already completed the MIP Accounting

Server Install and Granting Access to the MIP Share Directory, if there is a network.

This chapter describes the installation process for the MIP Accounting Workstation. This installation

provides the program files needed to run the system (the MIP Fund Accounting shortcut and executable

files). You can choose which modules to install on the system. Please carefully read each panel of the

wizard during installation.

The necessary files related to this installation are copied to the MIP Share directory of the server during

the MIP Accounting Server installation. There is only one executable (SETUP.EXE) for the workstation

install.

Important! Be sure to run SETUP.EXE as an administator.

Note: The user logged on to the workstation machine must be a member of the Local Administrators

group.

Ensuring Access to “All Users” Folder
Before you begin the workstation install, you must ensure that the workstation has access to the “All

Users” directory. The following steps should be completed:

1. Click Start>Run.

2. Enter the <local drive letter:> in the Open box.

3. Click OK. The system displays an explore window.

4. Open the Program Data folder. If you do not see the folder, go to the "View" tab on the upper left

corner of the file explorer window, then check the "Hidden items" checkbox to reveal the hidden

Program Data folder.

5. Ensure that the “All Users” and <user name> folders are listed. Also verify that each user that uses

Aatrix® (for 1099s, W-2s, 990s, etc.) has “Full Control” rights (right-click on

folder>Properties>Security tab). MIP Accounting cannot install successfully without these folders and

rights. These steps should be completed for each workstation running on Windows 10 or 11.
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Data Files and Directory Structure
When installing the MIP Accounting Workstation, the system and program files are stored on each

computer. After the workstation installation, the following directory structure exists on the drive and in the

directory that was specified during installation.

MIP Directory

The MIP Accounting Workstation installation creates a MIP directory on the local disk partition with the

most space. This directory contains the following folders:

HELP contains all the files associated with the online help system.

PROGS contains the executable (*.EXE) files required to run the system. Specific *.DLL files are

included in the PROGS directory. Do NOT delete any of these files.
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MIP Accounting Workstation Install
The MIP Accounting Server must be upgraded prior to upgrading the MIP Accounting Workstation.

Important! If you have already installed the MIP Workstation on your machine, you can run the

Workstation Update Tool to easily upgrade your workstation to the latest version of MIP Accounting. For

more information, see the MIP Fund Accounting Workstation Update section of this guide. If your

organization is hosted on the MIP Cloud (single-tenant AND multi-tenant organizations), the MIP

Support team will set up and manage the Workstation Update Tool for you. No action is required on your

part.

If you selected the Install MIP Accounting Workstation check box at the end of the Server Install, the

system automatically launches the Welcome panel of the MIP Accounting Workstation install.

When the existing data engine configuration is kept on each workstation, select

Start>Programs>MIP>MIP>{any application}. The system displays a message indicating a new version

is required; select Yes to automatically launch the MIP Accounting Workstation Installation.

If the auto launch fails, due to the data engine configuration changing or Windows OS users with User

Account Control turned on, follow the steps below to launch the MIP Accounting Workstation Install.

Note: You must access \MIP SHARE using a UNC Path, not a mapped drive. Mapped drives are okay as

long as they are consistent and persistent across all workstations, such as everyone having a G:\drive

mapped to MIP Share.

Click Start>Run.

Enter the <\\server name> in the Open box.

Click OK. The system displays an explore window with all the shared folders listed.

Open the MIP Share directory on the server.

Open the Setup folder and run SETUP.EXE.

Important! Windows OS Users - If the User Account Control is turned on, a message displays that “A

program needs your permission to continue,” click Continue to proceed.

The system automatically launches the Welcome panel of the MIP Accounting Workstation install, if you

selected the Install MIP Accounting Workstation check box at the end of the Server Install or opened an

application after the Server was updated.
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If you are installing the workstation only, go to the workstation machine and log on as a user with local

administrator rights. Navigate to the MIP Share directory (\\MIP Share) on the Server, open the Setup

sub directory, and select Setup.exe.

1. The Abila MIP Accounting Workstation InstallShield Welcome panel displays.

2. Click Next. Review the End User License Agreement and select the “I accept the terms in the license

agreement” option.

3. Click Next. Accept the default MIP destination folder (recommended), or use the Change button to

navigate to a different location.
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4. Click Next. The Custom Setup panel displays, which allows you to select the systems you would like to

install.

The Scheduler system is not merged into MIP Fund Accounting because it is an application used to

monitor scheduler activities. To prevent the Scheduler system from being installed, ensure that the “X”

(Entire feature will be unavailable) is selected. This designation prevents the installation of the

program files and the start menu shortcut for that system. You may find this useful when you need to

restrict a user from launching the Scheduler system.
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Note: If you do not install all systems now, but later decide you want to install the Scheduler

program files or start menu shortcut, you can do so using Start>Settings>Control Panel>Add or

Remove Programs. Select MIP Workstation and the Change button. The system displays the

Welcome panel of the Install wizard. Click Next. Then, on the Program Maintenance panel, select

the Modify option button, followed by the Next button.

5. Click Next. The Install Wizard is ready to install the program.

6. Click Install to begin the installation, or click Back to make changes to your installation settings.

7. The system begins upgrading the MIP Accounting Workstation software. This process may take

several minutes. The InstallShield Wizard Completed panel displays.
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8. Click Continue to complete the Workstation upgrade.

9. Additional installs launch after you click Continue to complete the Workstation upgrade. Allow any

additional installs to complete, and then click OK on the “Your install completed successfully” form.

10. This is the final window of the workstation installation. It verifies that the MIP Accounting Workstation

installed successfully. If applicable, click the Exit button on the MIP Accounting Installation Setup form.

Note: At the end of the Workstation install, reboot your computer only if prompted to do so.

11. If the MIP Accounting Workstation component is already installed on the server or you have installed

the Workstation on the server for the first time, you will need to open the application on the server to

complete the upgrade process, which allows the system to automatically update this component.

Note: If the MIP Accounting Workstation component is not installed on the server, a workstation

installation must be performed on each workstation that needs to run MIP Accounting.

12. Open the Organization>Add a Module wizard. Run through this wizard to add any new modules.

13. Open the Security>Set Up Organization Menus form to grant rights to new menu selections that are

part of any new modules that were added.

14. Optional, install Alerts on your IIS Web Server. For more information, see "Alerts Install" (page 56)

Troubleshooting

You may not be able to install because of an error from the "Windows Installer Coordinator". The Windows

Installer Coordinator may get stuck or fail during an install or update.
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If this Windows Installer Coordinator error appears, you must disable the Windows Installer

RDS compatibility.

1. Open the Windows "Run" function by pressing the Windows key + R, or typing "run" into the

Windows search bar.

2. Run "GPEDIT.MSC".

3. The Local Group Policy Editor will display. Open the "Administrative Templates" subfolder located

under the "Computer Configuration" heading.

4. Open the "Windows Components" folder.

5. Open the "Remote Desktop Services" folder.

6. Open the "Remote Desktop Session Host" folder.
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7. Open the "Application Compatibility" folder.

8. Select "Turn off Windows installer RDS compatibility" by double clicking.

9. Set this feature to "Enabled".

10. Proceed with the MIP installation.

MIP Accounting Workstation Update
Use the Workstation Update Tool to quickly download and install the latest version of MIP Accounting to

the workstation.

Note: If your organization is hosted on the MIP Cloud (single-tenant AND multi-tenant organizations),

the Support team will set up and manage the Workstation Update Tool for you. No action is required on

your part.

Important! Please note that the Workstation Update Tool only provides workstation updates, not server

updates. Follow the instructions in Existing User - Server Install to update the organizational database

on a server from a previous version.

1. Open the "MIP Workstation Updates" tool. You can do this from the Start menu, or from the hidden

applications menu on the Windows taskbar.
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Important! Be sure to run the Workstation Update Tool as an Admin.

2. Go to the "Download" tab and click Download Updates.

Note: The MIP Accounting version update files only need to be downloaded once per organization.

The version update files are downloaded into the MIP Share folder (MIP Share>Setup>Patches).

Once the first workstation on the server downloads the version update files, all other workstations on

the network will be able to install the update directly from the "Install" tab without downloading

anything first.

3. Go to the "Install Tab" and click Install Updates.



MIP Accounting Workstation Update

If the MIP Accounting version update files have already been downloaded onto a workstation, the other

workstations on the network may not see the "Download" tab. They will be able to install the update

directly from the "Install" tab.

Troubleshooting

If you receive an error about the required Windows Service not starting, take the following steps to correct

the issue:

1. Open the Windows Services app by navigating to the drive that MIP is installed on, then going to

Windows>System32>services.msc, or by typing "Services" into the Search bar from the Start menu

on the workstation.
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2. Right-click the "Mip.Updates.Client.ServiceContainer" service and click "Start".

If you are trying to open the Workstation Update Tool and nothing is happening, make sure you are

running the tool as an Admin. You may need to close the Workstation Update Tool from Task Manager

before trying to run it again as an Admin.



Chapter 7: Alerts Install

This chapter includes specific instructions on how to install the MIP Accounting Alerts on a web server.

Download MIP Accounting
1. To download MIP Accounting, click the link in the email received from your MIP sales representative

to open the MIP Accounting download page. Select the appropriate download link.

2. The system automatically runs SETUP.EXE. The MIP Accounting installation menu displays the

Setup tab.

3. Review the following documents: Quick Start, Installation Guide, and System Requirements. You can
print these documents or review them online.

Begin Installation Process

Before you begin, you must ensure the following:

The user logged on the server machine must be a member of the Local Administrators group, as well

as an Administrator on the database server.
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Verify that Microsoft

Verify that you have MIP Accounting installed and have accessed the system at least once.

Confirm the location and access to the MIP Accounting database server.

MIP Accounting Alerts Server Install

Complete the following steps to install MIP Accounting Alerts on the web server.

1. After reviewing the provided documentation, select the Setup Alerts tab.

2. Select the Begin Alerts Installation Process option. The system begins extracting the setup.exe file.

3. The system verifies that Microsoft ASP .NET Core Runtime version 8.0.8 or higher is installed. If your

web server does not have the latest versions, the MIP Accounting Alerts installation wizard cannot

continue. You must exit the wizard and restart it after you install the ASP.NET Core Runtime.

Important! If the User Account Control is not turned off, click Yes to allow the changes to the

computer.

4. The MIP Accounting Alerts InstallShield Wizard prepares to install. The Welcome panel displays.

Click Next.



MIP Accounting Alerts Server Install

5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”

option to continue with the Alerts Installation.

6. Click Next. Select the database server that you are installing to by using the drop-down menu, or

browse to the database location.

Then, select how you want to connect to this server. If "Server authentication" is chosen, enter the

Login ID and Password.
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7. Click Next. You are now ready to install MIP Accounting Alerts.

8. Click Install to begin, or use the Back button to make changes.

9. During the installation process, a progress bar displays, and several windows will open and close.

This process may take several minutes to complete.

10. When the installation is complete, the InstallShield Wizard Completed panel displays.



Setting Up Alerts

11. Click Finish to complete the install.

12. If applicable, click the Exit button on the MIP Accounting Installation Startup form.

Before you begin creating Real-time Alert notices, you will need to make sure everything is setup in

Administration. For more information about setting up Alerts, see How Do I Set Up Alerts? under the
Administration checklist in the MIP Accounting system's Online Help (Help>Checklists).

Setting Up Alerts
Complete these steps in the following order to begin creating Real-time Alert notices:

1. Complete the Optional Alerts Install:

On the server functioning as your network's web server,

The user logged on the server machine must be a member of the Local Administrators group, as

well as an Administrator on the database server.

Verify that Microsoft .NET Core Runtime version 8.0.8 or higher is installed.

Confirm the location and access to the MIP Accounting database server.

Download and extract the MIP Accounting installation, select the Setup Alerts tab, and complete

the Alerts Installation process. To get the latest download, see the Knowledgebase.

2. Review the "Setting Up Your Organization" checklist to ensure that the organization is set up properly.
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3. As a user with Administration rights, perform the following steps:

a. Ensure all of your users have email addresses and have been added to the organization using

the Security>Maintain Users form.

b. Ensure that the SMTP Email is set up and configured using the following steps:

i. Enter the Set Up SMTP Connection information using the Organization>Organization

Information>Email Setup tab.

ii. Enter the From and To email addresses to test your connection is set up correctly.

iii. Click the Send Test Email button.

iv. Click Save.

Note: beginning with MIP 2022.2, users have access to Office 365 for limited email

capabilities. However, if you want to set up automated email functions such as Alerts and

Report Binder Scheduler, you will still be required to use SMTP.

c. Create an Alert and assign users using the Organization>Set Up Alerts form. For more

information about setting up Alerts, see How Do I Set Up Alerts? under the Administration
checklist in the MIP Accounting system's Online Help (Help>Checklists).

d. Use Options>System Preferences to enter a default From email address for Alerts, However, if

the "Use Custom Credentials" check box is selected on the Organization>Organization

Information>Email Setup tab, the User email address entered there must be the default "From"

email address.

Note: System Users have the ability to turn off the Real-time In-product notifications, by clearing

the Connect to the Alert Server check box on the Options>User Preferences form. If not

selected, the alerts will continue to collect in the Message Center and Real-time Email Alert

Notices will be sent, but the number count on the Message Center will not reflect accurately.

http://documentation.abila.com/MIP_Core/Online_Help/Content/Reference/Administration_Checklist.htm
http://documentation.abila.com/MIP_Core/Online_Help/Content/Reference/Administration_Checklist.htm


Chapter 8: Uninstalling MIP Accounting

This chapter describes how to uninstall the MIP Accounting system.

Uninstalling Steps
The following components must be uninstalled in this order:

1. MIP Accounting Workstation

2. MIP Accounting Server

Before uninstalling, make a backup of the organization database; see Supplemental Maintenance for

more information. Uninstall only removes the files that the installation process copied to your

computer.

Data Import/Export,

Direct Deposit, EFT

for A/P, and Forms

Designer Users

When installing, the system copies files to the \MIP SHARE\IMPORT,

DDEPOSIT, EPAYAP, and FORMATS directories. During the uninstall process

these files are removed. If changes have been made to these files, either

change the names of the files or move them to another directory.

To Remove the MIP Accounting Workstation:

1. Go to Start>Settings>Control Panel.

2. Click Programs and Features.

3. Select MIP Workstation, and then click Uninstall.

–OR–

If you are uninstalling a MIP AccountingWorkstation on a computer, which acts as a client only (it is not on

the MIP Accounting Server), run the Uninstall on the Server through a UNC path (<server name>\MIP

Share\Setup\Uninstall).

To Remove the MIP Accounting Server:

1. Go to Start>Settings>Control Panel.

2. Click Programs and Features.

3. Select Abila MIP Server, and then click Uninstall.
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To Remove the MIP Accounting System including all Third Party Applications:

1. Use the Uninstall shortcut on <local drive letter:>\MIP Share\Setup folder.



Chapter 9: Help Documentation

This chapter describes how to access the MIP help documentation.

Accessing Documentation
The Installation and Getting Started guides are provided with your new system. Other guides and help

files are automatically installed as part of the Server Installation process. Therefore, documentation is

now easily accessible to all workstations through the \MIP Share\MIP Documentation\PDFs directory and

the \Program Files\MIP\Help directory.

Some product guides are available in PDF format. You can access these PDF files using Help>Product

Guides or click Help and Support>Resource Center>Product Guides on the Navigation pane. These

PDF files can be viewed and printed using a program, such as the Adobe® Reader®. To install Adobe

Reader, you can download it for free from http://www.adobe.com/.

The online help's “context-sensitive” feature is an easy way to get help when you need it most.

Context-sensitive means that the system knows where you are working within the system so when you

need help, you can press the F1 key or click the Help button. There is a wealth of information available

that you can use daily to help you in your work. By experimenting with online help, you learn to use the

system quickly, effectively, and efficiently.
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Chapter 10: Supplemental Maintenance

The following information is useful for backing up, restoring, and compressing your organizational

database.

Backing Up Organization Database
You can back up and restore all organization databases and the system database (NPSSQLSYS) for the

current version. When running a backup, the system creates an uncompressed copy of the database.

You can back up any database while users are in the system. However, to restore a database, all users

must exit the system.

1. As the Administrator, log on to MIP Fund Accounting (Start>All Programs>Abila>MIP Fund

Accounting). You do not have to select an Organization.

2. Open the File>Backup form.

3. Select the database you want to back up from the Database to Backup drop-down list.

4. Accept the default name (the database name, date, and time) or enter another name in the Backup to

File box.

5. If needed, click the Browse button and select the backup directory.

6. Click the Start button. The system backs up the database.

7. A dialog box will indicate the location of the backup when the process is finished.

Restoring Organization Database
1. As the Administrator, log on to MIP Fund Accounting (Start>All Programs>Abila>MIP Fund

Accounting). You do not have to select an Organization.

2. Open the File>Restoreform.

3. Select the database to restore from the drop-down list. If this is the first time a database has been

restored, its name is not available in the drop-down list; you must enter a name here.

4. Enter the name in the Restore to File box.
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5. Click the Browse button to locate the file.

6. Click the Start button.

The path to the MDF file that you backed up is stored in the backup file. When attempting to restore the

backup file, the system looks for the same path.

Compressing Organization Database
Before starting the compress process, all users must exit the system.

1. As the Administrator, log on to MIP Fund Accounting (Start>All Programs>Abila>MIP Fund

Accounting), but do not select an Organization.

2. Open the File>Compress form.

3. Select the database to compress from the drop-down list.

4. Click the Start button.

Note: Compressing large databases can take quite some time. If the actual database file has spaces in

the name, the compression program will not work.
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